Results 1 to 3 of 3

Thread: Ubuntu 8.04 and fglrx 8.5 issues.

  1. #1
    Join Date
    Oct 2007
    Posts
    321

    Default Ubuntu 8.04 and fglrx 8.5 issues.

    I'm having various problems with the latest release that appeared with the last release, here's a list.

    1) scrolling leads to heavy artifacting until you switch to another application that covers it, or in the case of tabbed applications switching between tabs also temporarily corrects the rendering. ( only happens when compiz is disabled and you use GTK Based applications )

    2) Gnome's notification widget for the panel is rendered improperly and does not properly update each time, however a full screen application fixes it for a little while until one has yet another update on it.

    I haven't tried much else, but these 2 bugs are the one's i need help with... i'm running on an Radeon X1900GT video card.
    Last edited by Dandel; 05-23-2008 at 09:08 AM. Reason: added some details.

  2. #2
    Join Date
    May 2008
    Posts
    45

    Default

    I don't have an answer for you but thought I'd contribute to my problems.

    I'm going to list regressions I have with the new driver over the previous one. I'm running Debian/Lenny, kernel 2.6.24, x1300, X 7.3.

    My main complaint is that when X is restarted my resolution seems to be randomly chosen, and is annoying when it is higher then my monitor supports. Everything worked fine with Catalysis 8.4

    The other one is that video flicker was much less if compiz was running on the previous driver over this one.

  3. #3
    Join Date
    Oct 2007
    Posts
    321

    Default

    oh i gave it a shot again, this time enabling/disabling what was suggested to cause the issues, and here's what i found.

    enabling/disabling the Textured2D and TexturedXRender does not fix any of the applications.

    gnome's system monitor causes full screen artifacts when compiz is not being used by gnome and you try to move it.

    and for those who are wondering, here's my xorg config file i used with the 8.5 drivers. ( minus a few options which i had enabled on 8.4 that caused performance boosts for me, namely the textured rendering.)

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Generic Keyboard"
    	Driver      "kbd"
    	Option	    "XkbRules" "xorg"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Configured Mouse"
    	Driver      "vmmouse"
    EndSection
    
    Section "Monitor"
    	Identifier   "Configured Monitor"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "Configured Video Device"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "UseFastTLS" "2"
    	Option	    "BackingStore" "off"
    	Option	    "XAANoOffscreenPixmaps" "off"
    	Option	    "OverlayOnCRTC2" "1"
    EndSection
    
    Section "Screen"
    	Identifier "Default Screen"
    	Device     "Configured Video Device"
    	Monitor    "Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    edit:

    did more testing... the bugs i am setting is related to GTK based applications only from what i can tell and mainly with compiz disabled ( don't know why this is, but it's odd that having compiz enabled would fix it ), and i spotted another bug, with what i am getting... 1600x1200 with compiz enabled only renders 1600x1050 of the screen, while 1280x1024 renders completely properly.
    Last edited by Dandel; 05-23-2008 at 08:41 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •