I've been tryng for over a week to get Ubuntu 6.06 installed onto my system, and the Ubuntu people (both forums and IRC channel) can't help (but not for lack of trying). I figure I must have either a defective hard drive, or a defective motherboard. Here's my tale of woe

System:
ASRock 939Dual Sata2 motherboard with 2.10 BIOS
AMD64 3500 Winchester (not overclocked)
1GB Patriot PC3200 RAM (not overclocked)
eVGA 7900GTX (not the overclocked one, and not overclocked by me) (brand new)
hda=new Seagate 200gb EIDE (brand new)
hdb=80gb Western Digital EIDE
sda=SATA1 160gb Western Digital
sdb=SATA2 160gb Western Digital
cda=LITE-ON CD/DVD writer (brand new)
keyboard and mouse are PS/2
19-inch LCD monitor with native resolution of 1280x1024.

Other info:
1) I'm using the onboard NIC and sound components.

2) I'm NOT using raid.

3) I'm NOT using the SATA2 controller at all, but it's set to "IDE " and is disabled in BIOS.

4) I'm NOT dual booting.


Observations:
1) Windows 2000 Pro runs flawlessly on this box. In case you're wondering, I have Wndows installed on a separate boot drive (80gb Western Digital EIDE), and I swap the two boot drives using a removable drive tray setup.

2) The Ubuntu 6.06 live cd boots up fine (even sees the NIC and sound components)


Problems:
1) If I try to install with the SATA drives connected, the install freezes at seemingly random spots near the end of the install process (88-97%).

2) If I disconnect the SATA drives, the install hangs after I click "restart computer" in the final dialog box. It hangs when it's trying to "shutdown the LVM volume groups". If I do a cold restart, it will start to boot into Linux, but will hang at "loading hardware drivers".

3) Last Monday, I got it installed, and it even booted into the OS, but I had other Windows things to do, so I shutdown and swapped the boot drives out. I used Windows for the rest of the week.

4) Just this last Saturday, I swapped the boot drives and tried to boot Ubuntu and it hung up at "loading hardware drivers". I haven't been able to boot or reinstall successfully since.


Things I've Tried:
1)Physically disconnecting the SATA drives

2) Disconnecting all USB devices

3) Turning off legacy USB and USB 2.0 support in the BIOS

4) Burning the distro CD at speeds from 8x to 48x

5) Burning to different brands of writable media

6) Installing the amd64 version of the distro

7) Non-graphical installers

8) Installing other distros (including older versions of Ubuntu).

I've tried everything I know to try, and some things other people have suggested, but the box is simply rejecting any install of Linux.


[b]Conclusion:

I consider myself to be pretty freakin' savvy where building a PC is concered - I've been doing it since about 1986 - but this has me completely stumped. Since there's no incompatible hardware in my setup, I think that one of two things is wrong:

1) The motherboard is flakey

2) The 200gb hard drive that I'm trying to install Linux on is flakey

My first instinct is to say that the act of installing Linux has somehow exposed a flaw in the motherboard, but at this point, it's just a guess since the live-cd boots without any problems at all.

Can anyone here provide any guidance?