Page 3 of 8 FirstFirst 12345 ... LastLast
Results 21 to 30 of 76

Thread: AMD/ATI + Linux + WINE = FAIL... all around.

  1. #21
    Join Date
    Aug 2007


    Another FGLRX + Wine bug I have from many FGLRX and Wine versions in NFS PS.
    The game status is marked as platinum under Wine with NVidia but there's only garbage with FGLRX.

  2. #22
    Join Date
    Nov 2007


    Quote Originally Posted by surfer View Post
    I don't doubt you are having problems with an inherently problematic driver. However, can you provide more information? We need to see anything in your kernel log having to do with DRM, your Xorg.0.log, and will wine work if you downgrade to 8.4? Also, try removing your entire ~/.wine directory and start with completely fresh settings.
    I have removed the .wine dir many times now trying to solve the problem. I can play ET:QW, Nexuiz and penumbra flawlessly (native). And because it works with wine 0.9.56 and with any resent fgrlx version I think I can safely say that this is a wine problem...
    Here is my xorg log:
    Last edited by ZedDB; 05-26-2008 at 04:14 PM.

  3. #23
    Join Date
    Oct 2007


    well.. hl2, tf2, portal etc, works under nvidia, but with fglrx and hd2xxx it does not work at all...

  4. #24
    Join Date
    Sep 2007
    Patras, Greece


    Lately I've only tried warcraft3 on wine, on my laptop with an ati 2600...
    With versions 0.9.60 and later I too get:
    libGL error: drmMap of framebuffer failed (Cannot allocate memory)
    libGL error: reverting to (slow) indirect rendering
    and also some missing effect or textures (the water on the main menu doesn't render correctly)
    I remember that some some wine/fglrx combination the game ran flawlessly, I think up to 0.9.59 wine, but not with fglrx 8.4 and 8.5 I could check that up...
    Another weird thing the indirect rendering error occurs no matter if use the -opengl parameter when I run the game (the rendering problem too), but when using -opengl the performance is decent, and when not I get about one fps.
    I'd gladly provide any more feedback that might be of help

  5. #25
    Join Date
    Dec 2007


    Watch this bug on Wine Bugzilla:
    The problem however was introduced with one of the newer fglrx releases, I think it was about 8.44. At least I can say that even older wine versions don't work with newest fglrx anymore.
    The bug report provides a patch that at least makes some games work.

  6. #26
    Join Date
    Mar 2008


    Dirty hack to make wine work (briefly tested with rc3)
    --- dlls/wined3d/state.c        7 May 2008 12:05:57 -0000       1.267
    +++ dlls/wined3d/state.c        30 May 2008 23:10:32 -0000
    @@ -2522,7 +2522,7 @@
             if(stage >= GL_LIMITS(texture_stages)) {
                 WARN("Bump env matrix of unsupported stage set\n");
             } else if(GL_SUPPORT(ARB_MULTITEXTURE)) {
    Sam&Max looks OK (crashed before)
    HL2 - graphics artifacts on highest settings, sometimes slow (quited silently before).

    HD2600 AGP, Catalyst 8.5

  7. #27
    Join Date
    Sep 2006


    Quote Originally Posted by Kano View Post
    It seems you are completely weird...
    Actually, what I say is true:

    Maybe you should investigate the situation more carefully:

    The WINE team have deliberately sabotaged WINE for years.

    Alexandre Julliard even works for Codeweavers. Talk about a conflict of interest.

    There is much sabotage of Linux to the benefit of the RIAA/MPAA Microsoft and other business ventures.

    See "The Linux Kernel SABOTEURS." @

    for another example.

  8. #28
    Join Date
    May 2008


    Jade, you're hillarious. It's not a secret that Codeweavers is using wines code for their CrossOver Software. They're just pushing changes/improvements they make back to wine. Basically they're just selling paid support for wine, just as RH and the like are selling support for linux.

  9. #29
    Join Date
    Jun 2008


    No work games:
    STALKER 1.006 , after check disk shows blank screen
    Everquest 2 ,after start i see cursor, and computer hangs with playing music of game.
    Oblivion Shivering Isles , launcher works fine,but game not, sometimes i hear 0.5 second of Bethesda logo sounds but game autoclose.
    Gothic 3 1.6
    After show Logo Gothic game show blank screen
    Neverwinter night2 -
    Launcher work fine, but game NOT!
    Gothic 2 - only splash - no game
    Gothic 1 - only splash - no game

    Work Fine (just info):
    Doom3 (native),World of warcraft (wine)
    Quake 4 (wine) ,Unreal Classic (wine) , Unreal (Native)

    I have [email protected]/AMD chipset 590X/AMD ATI Radeon HD3870X2 512MB/4GB Ram/320GB HDD/DVD-RW NEC 3510
    OS:Ubuntu 8 AMD64+ Wine 1.0rc4 +Catalyst 8.5 (but im trying a 8.4 so)
    I tried original installer and build self packages - this dont change effect
    I have this collection of videocards
    I fan of ATI ,one of many.

    Radeon X800GTO2 128Mb,
    Radeon X850XL 256Mb,
    Radeon X1800XL 256Mb
    Radeon X1950PRO 256Mb
    Radeon X2900XL 512Mb
    Radeon HD3870X2 512Mb

    All games and cards tested on proprietary fgrlx

    PS. How many years remain to normal support Ubuntu????

    With hope, Alexey

  10. #30
    Join Date
    Oct 2007


    This option was useful for me to get some games running:

    Maybe it will help the one or other if yiou too...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts