Page 8 of 8 FirstFirst ... 678
Results 71 to 76 of 76

Thread: AMD/ATI + Linux + WINE = FAIL... all around.

  1. #71
    Join Date
    Jan 2007
    Posts
    33

    Default wtf i'm still subscribed to this thread?

    I bought an NVidia card over a year ago and haven't looked back. I feel sorry for anyone that still uses ATI hardware in linux.

  2. #72
    Join Date
    Oct 2007
    Location
    Under the bridge
    Posts
    2,142

    Default

    Quote Originally Posted by Dinth View Post
    Ive got a same problem. I play (or want to play: Mount & Blade, Civ IV and Medieval 2. M&B works fine always (but crashes randomly), Medieval 2 never works (unhandled page fault ...) and civilization iv sometimes work (after new .wine installation - i do installation in same way - sometimes civilization iv works after it, and sometimes i got same error - unhandled page fault when tring to run it).
    Have you filed bugs in winehq? Out of those games, only M & B uses the video card. For the rest, it makes no difference what video card you are using.

  3. #73
    Join Date
    Jun 2008
    Location
    Melbourne
    Posts
    211

    Default

    Quote Originally Posted by surfer View Post
    I bought an NVidia card over a year ago and haven't looked back. I feel sorry for anyone that still uses ATI hardware in linux.
    I remember back in the day with nvidia, there was a period of about 8 months that I couldn't play games, no beta releases, no indication of a fix or anything. Even nowadays with my laptop things are the same.

    Having used ATI since the announcement of the OS drivers, while things have been touch and go, they have been making steady improvements. Agreed they're not close to nvidia drivers atm but I believe they will get there one day.

  4. #74
    Join Date
    Jun 2009
    Posts
    1,134

    Default

    Quote Originally Posted by storma View Post
    I remember back in the day with nvidia, there was a period of about 8 months that I couldn't play games, no beta releases, no indication of a fix or anything. Even nowadays with my laptop things are the same.

    Having used ATI since the announcement of the OS drivers, while things have been touch and go, they have been making steady improvements. Agreed they're not close to nvidia drivers atm but I believe they will get there one day.
    well same here i havent sold my 4850x2 quadfire setup only cuz of OSS driver (not yet usable in r7xx), jajajaja 600$ to use vesa but im waiting cuz OSS driver look is taking a great path + i wanna see what 3200 cores can do with openCL/gallium.

    note: i know fglrx exist but is completely unusable in my rig and yes i tried everything i just cant work like that for now ati git driver for 2d is awesome and winxp for games (i feel happy that i keep that 160 sata hdd around ) but still i have to admit nvidia drivers are awesome most of the time.

    my advise drop fglrx code, really if i wasnt a geek i would instant rma my amd gpus and get an gtx 280 sli system, but i wanna support you cuz i love amd cpus and you seems to put a nice effort in OSS driver. so keep working only in OSS driver nobody that do any real work o play with linux will miss fglrx at all, even if those nasty deadlock or screen heavy corrpution is very fun sometimes especially when you havent saved all the work :**

    about wine issues yes is fglrx fault not wine, why i say so? i have 2 game system a laptop and a desktop pc.

    laptop toshiba x205 game serie
    2 8800m sli
    raid 1 disk array sata 2 disk
    ubuntu 9.10 latest update

    desktop
    AMD athlon x4 620 @ 3.6 ghz with cmaster v8 cooler (yes i tried stock clock too)
    msi 790 FX gd-70 board quad CF 16x16x
    2 1 tb raid disk array (yes i tried with no arrays too)
    2 4850x2 aka 4 4850 gpus @ 685/1xxx
    1200 cmaster PSU
    ubutu karmic 9.10 latest update

    wine game lineage2, left 4 dead
    i installed everything from scrath in my laptop and then copyed and md5 confirmed copy to the desktop. aka exactly same soft as laptop.

    * laptop with latest nvidia 190.36 driver
    -super fast(almost same windows xp perfomance)
    -stable all the time
    -0% glitch or any corruption

    * desktop with latest fglrx 9.10 (i tried those before too up to 9.4)
    -even after googling fixes for hours is slow as a cow.
    -crossfire well the check widget is there but beside the mind blowing deadlocks nothing else happens
    -not stable at all (any wine app generate in time some nasty segfaults all around)
    -when i got it to work is heavily corrupted, can be reduced with ingame workaround but still sux

    obviously in win xp all work fine not excelent but fine and yes i tried with 1 4850x2 just in case and yes some freind with a 4890 tried too and the same

    so yes, you have to wait for OSS driver or fglrx to someday take a look of it, is not wine fault cuz in nvidia and intel works fine, try yourself and youll see

  5. #75
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,595

    Default

    Quote Originally Posted by jrch2k8 View Post
    so yes, you have to wait for OSS driver or fglrx to someday take a look of it, is not wine fault cuz in nvidia and intel works fine, try yourself and youll see
    I've heard Intel users having plenty of issues with Wine too. *shrug*

  6. #76
    Join Date
    Jun 2009
    Posts
    1,134

    Default

    Quote Originally Posted by nanonyme View Post
    I've heard Intel users having plenty of issues with Wine too. *shrug*
    well my laptop is an acer aspire core2 intel cpu and 945 gpu and it works fine with wine at render lvl but ofc is an ultra slow chip to begin with, so even in windows is slow. but so far renders fine and wine is stable with it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •