Page 4 of 8 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 71

Thread: Open-Source ATI Driver Achieves 3D Success

  1. #31
    Join Date
    Dec 2007
    Posts
    2,279

    Default

    Quote Originally Posted by slacker View Post
    how can I solve this?
    Install the right mesa? Did you build from source? Install packages? If you installed from pacakges, you'll need the mesa/dri/gl package (name varies depending on distro).

  2. #32
    Join Date
    Nov 2006
    Posts
    72

    Default

    I did install mesa from sources, git master...
    But not manually, with a gentoo ebuild: maybe there's something wrong with it. I will try to get more info.
    thanks

  3. #33
    Join Date
    Dec 2007
    Posts
    2,279

    Default

    Quote Originally Posted by slacker View Post
    I did install mesa from sources, git master...
    But not manually, with a gentoo ebuild: maybe there's something wrong with it. I will try to get more info.
    thanks
    When you build mesa, you want the dri build target. I'm not sure how gentoo does it.

  4. #34
    Join Date
    Nov 2006
    Posts
    72

    Default

    ok, so I manually installed mesa from sources.
    It installed stuff in /usr/local/lib, so I had to manually copy it to /usr/lib/.

    Now glxinfo gives:

    $ LIBGL_DEBUG=verbose glxinfo
    name of display: :0.0
    libGL: XF86DRIGetClientDriverName: 4.3.0 r300 (screen 0)
    libGL: OpenDriver: trying /usr/local/lib/dri/r300_dri.so
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 5, (OK)
    drmOpenByBusid: Searching for BusID pci:0000:01:00.0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 5, (OK)
    drmOpenByBusid: drmOpenMinor returns 5
    drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
    Error: couldn't find RGB GLX visual

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    ----------------------------------------------------------------------
    0x23 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x24 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x25 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x26 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x27 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x28 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x29 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x2a 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x2b 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x2c 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x2d 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x2e 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x2f 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x30 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x31 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x32 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    0x6a 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

  5. #35
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,093

    Default

    slacker, you should use

    ./autogen.sh --prefix=/usr
    or
    ./configure --prefix=/usr

    in the future, so that it installs in the correct directory.

  6. #36
    Join Date
    Nov 2006
    Posts
    72

    Default

    I tried that.. Same error as above:
    Error: couldn't find RGB GLX visual
    Is there a way to "make uninstall" ?

  7. #37
    Join Date
    Feb 2007
    Posts
    22

    Default

    Quote Originally Posted by agd5f View Post
    Dave just merged the r500-support branch into mesa git master, so it should be much easier to get up and running now.
    Did this code make it into Mesa 7.1 RC1?

  8. #38
    Join Date
    Nov 2006
    Posts
    72

    Default

    Quote Originally Posted by elenius View Post
    Did this code make it into Mesa 7.1 RC1?
    afaics no: http://cgit.freedesktop.org/mesa/mesa/log/

  9. #39
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,285

    Default

    I think the merge happened about 8 hours after RC1 was created, but if there is a subsequent RC for 7.1 the R5xx support should be picked up.

    The changes are confined to the drivers/dri/r300 folder so no risk to the rest of Mesa.

  10. #40
    Join Date
    Jan 2007
    Posts
    17

    Default me too

    I am currently using Fedora 7 with the proprietary ATI driver. I want to switch in the next month or so to F9. It would be very nice to have a step by step guide to get a decent free driver up and running.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •