Results 1 to 8 of 8

Thread: Hard lockups during 3D/R500 in OSS radeon?

  1. #1
    Join Date
    Jan 2007
    Posts
    33

    Default Hard lockups during 3D/R500 in OSS radeon?

    Hello,
    I read Michael's article on the state of 3D/R500 in the OSS radeon driver. It mentions frame rate dips in some games, which I have not experienced. However, I do get consistent hard lockups whenever using openarena or compiz (it probably affects every 3D app but these are the only 2 things I've been testing with). The lockups happen consistently to the point where I can't use compiz for more than an hour or so (but often it only takes a few minutes of usage) before dragging a window locks up the whole PC. It seems like something is still seriously wrong.

    All of my X libs/programs are up to date with their respective master GIT repositories (I built everything on May 30).

    Is this a known issue? Is anybody else experiencing this issue? In the GIT commit log it's mentioned that the R500 3D support is now comparable with the R300 support. Is this happening to R300 users too?

    Also, what can I do so that I can capture useful information when these hard lockups do occur?

    I remain committed to helping this driver in any way I can and that's why I bring this issue to the table.

    Thanks.
    Last edited by surfer; 06-01-2008 at 03:30 AM.

  2. #2
    Join Date
    Nov 2006
    Posts
    72

    Default

    Unfortunately I have been experiencing the same, but only using xserver from git (I need it because I'm on x86_64).

    I don't use compiz, but kde4 instead: when I click to activate composite effects my pc hangs immediately, and I have no control over it anymore.

    Also, it hangs the same way when logging out from a kde4 session (no effects enabled). The thing is... it's not completely frozen, because the mouse cursor in kdm keeps blinking!! But I still can't shut it down properly...

    And finally it randomly froze after an hour I was watching a movie with mplayer.

    Now, I have tried disabling the loading of the DRM module, and so far It didn't freeze. So in my case I'm pretty sure xserver from git + drm is the cause

    And of course, I can't get any info about the freeze, nor in Xorg.0.log or syslog

    EDIT: I have a mobility X1400 card

  3. #3

    Default

    same problem here, except i can usually recreate mine by starting a 3D game in compiz. compiz works great here, but as soon as i start an opengl app => hard lock.

    i'm running latest git everything on an x1300.

    let us know if there are any traces we can give that would help.

  4. #4
    Join Date
    Nov 2006
    Posts
    72

    Default

    By setting "vblank_mode=0" I don't get the lockup when activating kde4 desktop effects, but the screen goes completely black! KDE is still alive and all, but I just can't see anything
    But using 3d applications seems fine so far (only tried ut2004 for a 15 ins match)..

  5. #5
    Join Date
    Dec 2006
    Posts
    82

    Default

    same problem here.

    I notice using opengl apps ontop of compiz speeds this process up. ( from my seat of the pants testing)

    anyone know of a relevant tracker item or should one of us file it?

  6. #6
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,281

    Default

    I haven't seen a bug filed on this specific issue. Is anyone seeing the problem on pre-5xx chips ?

  7. #7
    Join Date
    Nov 2006
    Posts
    72

    Default

    I added a bug: https://bugs.freedesktop.org/show_bug.cgi?id=16198

    Please, add your own info

  8. #8
    Join Date
    Feb 2008
    Posts
    15

    Default

    Hi,

    I experienced lockups when activating compiz before. (normal 3d stuff worked stable: (tested glxgears, google earth and nexuiz)

    Tonight I've updated the drm modules, necessarily after a kernel update on ubuntu hardy, but the good news: compiz seems to work now!

    I will post in the bug report if it continuous to work.

    NB I have a X1300.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •