Results 1 to 2 of 2

Thread: Two Suggestions

  1. #1
    Join Date
    Feb 2008
    Posts
    154

    Default Two Suggestions

    Hi, I am a big fan of PTS, and I am planning on doing a project to compare ATI and Nvidia cards in my possession. I'm doing ATI first and I have a problem with soft particles in etqw. Apparently this is a known issue. With soft particles enabled, the benchmark is unbearably slow and grinds to a halt in the middle. With soft particles disabled, everything is peachy. I took the liberty of making my own fix:
    Code:
    		<Option>
    			<DisplayName>Soft Particles</DisplayName>
    			<Identifier>r_softParticles</Identifier>
    			<Menu>
    				<Entry>
    					<Name>On</Name>
    					<Value>1</Value>
    				</Entry>
    				<Entry>
    					<Name>Off</Name>
    					<Value>0</Value>
    				</Entry>
    			</Menu>
    		</Option>
    If you don't know, that goes in /usr/share/phoronix-test-suit/pts/test-profiles/etqw.xml and etqw-demo.xml after the first option to set resolution. I just copied/pasted my way to that fix, but it works fine on this end

    My second suggestion stems from the fact that pts diagnostics detects the amount of video memory in my x1950pro as 256mb when it is actually 512mb. I see that it is reading the xorg log in /var/log, but that is detecting the wrong value for my video ram. In ATI's CCCLE it detects the full 512mb. I really don't know what to suggest here other than finding another means to detect video memory or allow the user to set it.

    Aside from this, my experience so far has been positive. Keep up the great work
    Last edited by Max Spain; 06-14-2008 at 01:24 PM.

  2. #2

    Default

    Quote Originally Posted by Max Spain View Post
    My second suggestion stems from the fact that pts diagnostics detects the amount of video memory in my x1950pro as 256mb when it is actually 512mb. I see that it is reading the xorg log in /var/log, but that is detecting the wrong value for my video ram. In ATI's CCCLE it detects the full 512mb. I really don't know what to suggest here other than finding another means to detect video memory or allow the user to set it.
    If you're using the git code (or soon-to-be 1.0.1) you can override it with:

    VIDEO_MEMORY=512 phoronix-test-suite benchmark etqw

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •