Page 13 of 16 FirstFirst ... 31112131415 ... LastLast
Results 121 to 130 of 158

Thread: AMD Catalyst 8.6 Linux Driver

  1. #121

    Default

    I was able to regain the use of all 8GB of memory by building my MTRR tables by hand. What a pain, but it wasn't the fault of ATI's driver, it is my BIOS.

  2. #122
    Join Date
    May 2008
    Posts
    45

    Default

    Quote Originally Posted by Chris Clearwater View Post
    I was able to regain the use of all 8GB of memory by building my MTRR tables by hand. What a pain, but it wasn't the fault of ATI's driver, it is my BIOS.
    I am about to try to fix my mtrr. Could you give some tips or sources to study?
    Is performance as good as before? (in memory related tasks)

  3. #123

    Default

    Can you paste the following things:

    1) The output of 'cat /proc/mtrr'
    2) Amount of GPU RAM
    3) Amount of System RAM

    Performance should be the same, you are just fixing bad mtrr entries.

  4. #124
    Join Date
    May 2008
    Posts
    45

    Default

    Code:
    > cat /proc/mtrr 
    reg00: base=0x00000000 (   0MB), size=4096MB: write-back, count=1
    reg01: base=0xe0000000 (3584MB), size= 512MB: uncachable, count=1
    reg02: base=0xd0000000 (3328MB), size= 256MB: uncachable, count=1
    reg03: base=0x100000000 (4096MB), size=1024MB: write-back, count=1
    reg04: base=0x130000000 (4864MB), size= 256MB: uncachable, count=1
    reg05: base=0xcff00000 (3327MB), size=   1MB: uncachable, count=1
    4GB ram, 512MB video RAM

  5. #125

    Default

    Do you have 1MB memory hole enabled in BIOS? It would say something like "Memory hole, 15MB-16MB". Disable it if you find the option (I have it in my Asus BIOS) and paste your new /proc/mtrr.
    Last edited by Chris Clearwater; 07-01-2008 at 11:45 AM.

  6. #126
    Join Date
    May 2008
    Posts
    45

    Default

    I know the option, but there is no such thing in gigabyte ex38-ds5 BIOS
    neither is there remap options

  7. #127
    Join Date
    Jun 2008
    Posts
    16

    Default

    Opening a second Xserver freezes the system completely and I have to do a hard reboot.

  8. #128
    Join Date
    Dec 2007
    Location
    /dev/hell
    Posts
    297

    Default

    Quote Originally Posted by ningo View Post
    Opening a second Xserver freezes the system completely and I have to do a hard reboot.
    4 xservers are too much!

    since fglrx already uses 2 xservers on it's own

  9. #129
    Join Date
    Jul 2008
    Posts
    4

    Default

    Quote Originally Posted by alec View Post
    I know the option, but there is no such thing in gigabyte ex38-ds5 BIOS
    neither is there remap options
    Hi!

    Did you proceed somehow? I have the same Problem and just discovered this thread. ( GA-P45-DS3 with 4GB and Sapphire 4850 )

    Regards,

    ingo

  10. #130

    Default

    Sorry for not replying sooner. Here is the mtrr script I use for 4GB:

    Code:
    #!/bin/bash
    
    echo "disable=0" >| /proc/mtrr
    echo "disable=1" >| /proc/mtrr
    echo "disable=2" >| /proc/mtrr
    echo "disable=3" >| /proc/mtrr
    echo "disable=4" >| /proc/mtrr
    
    echo "base=0x00000000 size=0x80000000 type=write-back" >| /proc/mtrr
    echo "base=0x80000000 size=0x40000000 type=write-back" >| /proc/mtrr
    echo "base=0xc0000000 size=0x10000000 type=write-back" >| /proc/mtrr
    
    echo "base=0xd0000000 size=0x10000000 type=uncachable" >| /proc/mtrr
    
    echo "base=0x100000000 size=0x20000000 type=write-back" >| /proc/mtrr
    echo "base=0x120000000 size=0x10000000 type=write-back" >| /proc/mtrr
    It might be different depending on your configuration. The idea is the mask all your memory as "write-back", except for the PCI addressable space (256M) as "uncachable" and leave your video card memory (512M for 4850) unmasked. And you have to do this using power of 2 sized blocks.

    Here is my /proc/mtrr after applying the script, notice the 256M unchachable area starting at 3.25GB and the 512M gap starting at 3.5GB:

    Code:
    reg00: base=0x00000000 (   0MB), size=2048MB: write-back, count=1
    reg01: base=0x80000000 (2048MB), size=1024MB: write-back, count=1
    reg02: base=0xc0000000 (3072MB), size= 256MB: write-back, count=1
    reg04: base=0x100000000 (4096MB), size= 512MB: write-back, count=1
    reg05: base=0x120000000 (4608MB), size= 256MB: write-back, count=1
    Edit: It seems the reg03 was removed somehow, it was a 256M uncacheable area, maybe I am doing something wrong :-) I wish the BIOS reported the mtrr correctly.
    Last edited by Chris Clearwater; 07-04-2008 at 08:43 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •