Page 6 of 16 FirstFirst ... 45678 ... LastLast
Results 51 to 60 of 158

Thread: AMD Catalyst 8.6 Linux Driver

  1. #51
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,099

    Default

    The flickering video deal is not exactly a bug. It has been explained several times now. Bridgman keeps saying that running apps. in fullscreen should alleviate the problem, but that hasn't worked for me until this driver release. With the 8.6 I can finally game (in fullscreen) and watch videos (in fullscreen) while having Compiz on, as long as I don't have any other windows active. This holds true with Mplayer, Totem, and VLC (using whatever versions are default in Hardy), and for several games (Nexuiz, Alien Arena, Sauerbraten, Doom 3, Precipice of Darkness Ep1, Glest, Warsow, Urban Terror, Teeworlds).
    The packaging scripts are indeed semi-broken, but the auto installer works fine.
    Only problems I have with the driver are segfaults and horrible in game performance after a prolonged session, which is new for me (8.4 and 8.5 had none of these issues). I still get horizontal tears on screen when using Xv and OpenGL, but everytime it seems to be less apparent (hopefully by the next release it's gone for good).

  2. #52
    Join Date
    Apr 2007
    Location
    Bulgaria
    Posts
    269

    Default

    Quote Originally Posted by Melcar View Post
    but everytime it seems to be less apparent
    Are you forcing yourself to believe so?

  3. #53
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,099

    Default

    Quote Originally Posted by sundown View Post
    Are you forcing yourself to believe so?
    There is no more tearing on my 200M. The replacement x800 I have on my desktop still shows distortion on the top half of the screen (horizontal line going from left to right).

  4. #54
    Join Date
    Mar 2008
    Posts
    29

    Default

    @melcar

    like you, if i have compiz enabled and i watch video in fullscreen mode for example with vlc, i don't have problems but if i watch video in window mode, i have flickering.

  5. #55

    Default

    I installed these drivers in Ubuntu 8.04 using "--buildandinstallpkg Ubuntu/hardy".

    Problems:
    1.Horizontal visual tearing when playing videos-->the card spews frames faster than the monitor/TV can finnish displaying.
    2.The fan is constantly on and I am forced to use the special version of radeontool.

  6. #56
    Join Date
    Dec 2006
    Posts
    25

    Default

    ....looked around at this new driver release, and yet again i am so glad that my new Lenovo laptop is on the way with NVIDIA to my office.

    Sorry ATI, thanks for a long painful yet some time fun ride.

    Please check this thread
    http://forums.fedoraforum.org/showpo...&postcount=135

    look at the date, May 28, 2008 nvidia released driver that fully support latest kernel and latest Xorg server.

    today is June 19th... and yet nothing from ATI to Fedora. what is the deal with ATI??? move faster or you will be loosing people. and i was waiting... not complaining... but this is way too long.

    thanks to all enjoy.

    PS. don't get me started about % of users with Fedora, or that is a bleeding edge, or anything else. if some companies can do this, others should be able too.

  7. #57
    Join Date
    Jan 2008
    Posts
    112

    Default

    -I can log out(!!)
    -running "X :1 -layout TV" still results in an unrecoverable black screen lockup
    -Attempts to run "X -layout TV" from a console (without X running already) were foiled by fglrx - after rebooting, before logging in with KDM, I VT-switched to VT1. Then I tried to run "sudo /etc/init.d/kdm stop" only to get an error message about KDM not stopping. Repeated attempts to stop kdm fail. OK may as well login now right? VT-switching to VT7 results in the cursor on VT1 vanishing and the screen locking where it is (on VT1). Can't VT-switch anywhere, can't enter any more commands, but at least the Magic SysReq key works.
    -still have to edit authatieventsd.sh manually to point to /var/run/xauth - this has been an issue since I started trying to use the ATI cards I've bought, back when 8-3 was current
    -had to link libfglrx_gamma.so.1.0 to libfglrx_gamma.so.1 manually before the packages would build. I read about the fix in an Ubuntu thread which I believe was in reference to 8-4.

    FINAL TALLY:
    :1
    :4

    It's been zero happy smilies since I bought an HD3650, so I guess that's something. But why on earth does everyone who those last two items apply to have to apply those fixes themselves, driver after driver??

    Why is it that AMD can produce a perfectly functional, not-completely-insulting driver for Windows but Linux operating systems get this hit or miss BS? fglrx is a joke.



    edit:
    (on an HD3870)
    $ aticonfig --list-powerstates
    Error: POWERplay is not supported on your hardware.

    $ aticonfig --lsp
    Error: POWERplay is not supported on your hardware.

    Last edited by oblivious_maximus; 06-19-2008 at 04:42 PM.

  8. #58
    Join Date
    May 2008
    Posts
    3

    Default

    To me it seems that this version brings a small performance gain in OpenGL apps (blender & freecad), on a Xpress200.

    - several areas of blender continue as slow as before, mainly everything that is 2d (texts & menus). The file selector screen is terribly slow when navigating in folders full of items. There also seems to be a small "lag" when switching window type.

    - but several things are better. Still no dotted lines, but select/deselect has almost normal speed now. UVmapping screen also works at normal speed now.

    - still a lot of 3d-related apps do a segfault on exit, including fglrxinfo himself

    For the rest, I haven't seen any change since 8.5...

  9. #59
    Join Date
    Dec 2007
    Posts
    28

    Unhappy

    Quote Originally Posted by Mithrandir View Post
    Why don't you use open source driver? It works quite well with X200M.
    open source driver works very slow and buggy with my X200M (RC410)
    so fglrx is only way, with tearing in 3D but X doesn't crash every minute.

  10. #60
    Join Date
    Feb 2008
    Posts
    34

    Default

    "The flickering video deal is not exactly a bug", if so, why doesn't it happen on nvidia's drive? Who can explain to me?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •