Aphax, I'm not sure about this, but maybe you really broke you CPU while overclocking. Though I'm currently using an Abit AN8 SLI mainboard myself and I'm not really that pleased with it.
Actually I can't get my new 1 TB hard drive to format correctly with ext3. Every time I tried it, the system just hangs up. Well while searching for the problem, I read about some linux related bugs, but it also could be a hardware (especially mainboard) problem I guess.

Even though I have to thank Abit for there absolutely broken Windows(tm) drivers to bringing me to the linux platform at all! Back than in 2006 I didn't got Windows XP working stable on this Abit mainboard. Every few days the system crashed completely.
After a few weeks of research, I came to the conclusion that the awful drivers caused the problem. I installed Ubuntu Linux and everything worked just as it should, though I had to learn the whole thing from scratch for the following few month :P


Well, with a pricey mainboard, you can also have the same troubles, but this time I want to try that out and invest a lil bit more as usually.