Results 1 to 10 of 39

Thread: RV770 Support Added To RadeonHD Driver

Threaded View

  1. #31
    Join Date
    Jul 2008
    Posts
    21

    Default xorg still goes crazy....by short moments

    I have reported before that in my system, the CPU was used intensively by xorg. With the ATI proprietary fglrx driver, it helped to reduce the slowliness in the applications, and eliminated dvd jerky playback in gnome.

    But in KDE is a different story. Playing a DVD with Kaffeine gives black rectangles flickering in the screen. Clicking in the menus of Kaffeine cause them to flicker too. If Kaffeine is reduced to a small window and another application cover is full screen, then I can see the black window of Kaffeine overlaying the application.

    Top shows also that xorg, both in Gnome and KDE, uses the CPU at very high %, although this only for a short moment. But this is not normal. My previous system had a 1GHz CPU with an old Radeon 9250 card and never saw that kind of problems.

    I still believe that the ATI propietary driver still does not provide perfect support for this integrated gpu, HD-3200

    Or can someone with a similar system tell me if my xorg.conf should be modified? Here is my present configuration. Thanks for your suggestions.

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Default Screen" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "Files"

    # path to defoma fonts
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/X11R6/lib/X11/fonts/misc"
    FontPath "/usr/share/fonts/X11/cyrillic"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    # Load "extmod"
    SubSection "extmod"
    Option "omit xfree86-dga"
    EndSubSection
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "Monitor"
    Identifier "AL2223W"
    Option "DPMS"
    EndSection

    Section "Device"

    Identifier "ATI Technologies Inc ATI Default Card"
    Driver "fglrx"
    Option "UseInternalAGPGART" "yes"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "MonitorLayout" "AUTO, AUTO"
    Option "UseEvents" "boolean"
    # Option "NoAccel" "false"
    # Option "DRI" "true"
    # Option "RenderAccel" "true"
    # Option "XAANoOffscreenPixmaps" "true"
    # Option "AccelMethod" "EXA"
    # Option "FBTexPercent" "50"
    BusID "PCI:1:5:0"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "ATI Technologies Inc ATI Default Card"
    Monitor "AL2223W"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1680x1050" "1600x1200" "1440x1440" "1280x1024" "1280x960" "1280x800" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1680x1050" "1600x1200" "1440x1440" "1280x1024" "1280x960" "1280x800" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1680x1050" "1600x1200" "1440x1440" "1280x1024" "1280x960" "1280x800" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1680x1050" "1600x1200" "1440x1440" "1280x1024" "1280x960" "1280x800" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1680x1050" "1600x1200" "1440x1440" "1280x1024" "1280x960" "1280x800" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1680x1050" "1600x1200" "1440x1440" "1280x1024" "1280x960" "1280x800" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "1"
    EndSection
    Last edited by Maxei; 07-26-2008 at 11:58 AM. Reason: correction

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •