Page 5 of 5 FirstFirst ... 345
Results 41 to 49 of 49

Thread: Catalyst 8.7

  1. #41
    Join Date
    Oct 2007
    Posts
    51

    Default

    So I see conflicting info, does this support kernel 2.6.26 or not?

  2. #42
    Join Date
    Aug 2007
    Posts
    6,673

    Default

    Possible using a patch, but it was deleted from phorogit. My script has it included too:

    http://kanotix.com/files/install-fglrx-debian.sh

    Works directly with a system where dkms is preinstalled or installable. That means it works for Ubuntu and for Debian when

    http://linux.dell.com/dkms/dkms_2.0....buntu1_all.deb

    is installed. This does _not_ fix the ABI error with Xserver 1.5.

  3. #43
    Join Date
    Mar 2008
    Posts
    20

    Default

    Code:
    i will stick with radeon 6.9.0 on my mobility 1600...its much better then this
    I thought 6.9.0 did not support compiz? Do you have compiz running on it?

    paul

  4. #44
    Join Date
    Jul 2008
    Posts
    2

    Default

    As for games, they're a recreational pass time, they should be low on the list of priorities.
    Oh please. Getting a high end graphics card is because of games. I could buy something low-end if I didn't prioritize games.

  5. #45
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,565

    Default

    Quote Originally Posted by paul View Post
    Code:
    i will stick with radeon 6.9.0 on my mobility 1600...its much better then this
    I thought 6.9.0 did not support compiz? Do you have compiz running on it?

    paul
    AFAIK the changes related to Compiz were all in the drm and mesa drivers not radeon, so 6.9.0 should be OK for Compiz on 5xx if you have the right bits for the rest of the driver stack. Just be aware that the latest version of Mesa (which you probably need) also needs a very recent X server so you'll probably have to update X as well.

    The good news is that the combination seems to work quite nicely.

  6. #46
    Join Date
    Jun 2008
    Posts
    21

    Default

    what about slow 2D performance? browsing in konq is very slow (refreshing).

  7. #47

    Default

    I found 2 bugs on my system (Debian unstable, 32 bit, kernel 2.6.25, Radeon 3870, nearly empty xorg.conf):

    If I start my kernel with vga=31b the X Server crashes with:
    (EE) fglrx(0): PreInitDAL failed

    Backtrace:
    0: /usr/bin/X11/X(xf86SigHandler+0x7e) [0x80c914e]
    1: [0xffffe400]
    2: /usr/lib/xorg/modules/drivers//fglrx_drv.so(amdPcsFree+0x36) [0xb7942216]
    3: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxPreInit+0x2af) [0xb791b90f]
    4: /usr/bin/X11/X(InitOutput+0xa0f) [0x80ab33f]
    5: /usr/bin/X11/X(main+0x2b1) [0x8074591]
    6: /lib/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7dde455]
    7: /usr/bin/X11/X(FontFileCompleteXLFD+0x21d) [0x8073a81]

    Fatal server error:
    Caught signal 11. Server aborting
    I don't know if this happens with old drivers.


    The second bug concerns suspend to disc. After the first system boot (not resuming) it's necessary to start a video. If not the system will hang on playing a video after resuming. This concerns all releases this year.

    I don't know if there is a progress with my mtrr problem under 64 bit since i'm not using 64 bit anymore.

  8. #48
    Join Date
    Dec 2007
    Location
    /dev/hell
    Posts
    297

    Default

    Quote Originally Posted by zappbrannigan View Post
    I found 2 bugs on my system (Debian unstable, 32 bit, kernel 2.6.25, Radeon 3870, nearly empty xorg.conf):

    If I start my kernel with vga=31b the X Server crashes with:
    (EE) fglrx(0): PreInitDAL failed

    Backtrace:
    0: /usr/bin/X11/X(xf86SigHandler+0x7e) [0x80c914e]
    1: [0xffffe400]
    2: /usr/lib/xorg/modules/drivers//fglrx_drv.so(amdPcsFree+0x36) [0xb7942216]
    3: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxPreInit+0x2af) [0xb791b90f]
    4: /usr/bin/X11/X(InitOutput+0xa0f) [0x80ab33f]
    5: /usr/bin/X11/X(main+0x2b1) [0x8074591]
    6: /lib/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7dde455]
    7: /usr/bin/X11/X(FontFileCompleteXLFD+0x21d) [0x8073a81]

    Fatal server error:
    Caught signal 11. Server aborting
    I don't know if this happens with old drivers.


    The second bug concerns suspend to disc. After the first system boot (not resuming) it's necessary to start a video. If not the system will hang on playing a video after resuming. This concerns all releases this year.

    I don't know if there is a progress with my mtrr problem under 64 bit since i'm not using 64 bit anymore.
    Here on M76 - Mobility Radeon HD2600:

    The second happens to me too here (with all versions of fglrx with all versions of Xorg and with all versions of the kernel but under 64bit)

    For the first I get it even without specifying anything to the kernel! (but sure with xserver-1.4.*, with xserver 1.3 not tested, and every kernel )
    http://www.phoronix.com/forums/showthread.php?t=11570

    so, what about this!?

  9. #49

    Default

    Quote Originally Posted by Vighy View Post
    For the first I get it even without specifying anything to the kernel! (but sure with xserver-1.4.*, with xserver 1.3 not tested, and every kernel )
    http://www.phoronix.com/forums/showthread.php?t=11570
    No your problem seems to be different. My XServer crashes later.
    Code:
    (II) fglrx(0): === [atiddxPreInit] === begin
    (II) Loading sub module "vgahw"
    (II) LoadModule: "vgahw"
    (II) Loading /usr/lib/xorg/modules//libvgahw.so
    (II) Module vgahw: vendor="X.Org Foundation"
    	compiled for 1.4.2, module version = 0.1.0
    	ABI class: X.Org Video Driver, version 2.0
    (II) fglrx(0): PCI bus 1 card 0 func 0
    (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
    (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
    (==) fglrx(0): Default visual is TrueColor
    (**) fglrx(0): Option "DPMS" "true"
    (II) fglrx(0): Loading PCS database from /etc/ati/amdpcsdb
    (==) fglrx(0): RGB weight 888
    (II) fglrx(0): Using 8 bits per RGB (8 bit DAC)
    (**) fglrx(0): Gamma Correction for I is 0x06419064
    (==) fglrx(0): Gamma Correction for II is 0x06419064
    (==) fglrx(0): Buffer Tiling is ON
    (--) fglrx(0): Chipset: "ATI Radeon HD 3870" (Chipset = 0x9501)
    (--) fglrx(0): (PciSubVendor = 0x1002, PciSubDevice = 0x2542)
    (--) fglrx(0): board vendor info: original ATI graphics adapter
    (--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
    (--) fglrx(0): MMIO registers at 0xfe9e0000
    (--) fglrx(0): I/O port at 0x0000d000
    (==) fglrx(0): ROM-BIOS at 0x000c0000
    (II) fglrx(0): Primary V_BIOS segment is: 0xc000
    (II) Loading sub module "vbe"
    (II) LoadModule: "vbe"
    (II) Loading /usr/lib/xorg/modules//libvbe.so
    (II) Module vbe: vendor="X.Org Foundation"
    	compiled for 1.4.2, module version = 1.1.0
    	ABI class: X.Org Video Driver, version 2.0
    (II) fglrx(0): VESA BIOS detected
    (II) fglrx(0): VESA VBE Version 3.0
    (II) fglrx(0): VESA VBE Total Mem: 16384 kB
    (II) fglrx(0): VESA VBE OEM: ATI ATOMBIOS
    (II) fglrx(0): VESA VBE OEM Software Rev: 10.67
    (II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc. 
    (II) fglrx(0): VESA VBE OEM Product: RV670
    (II) fglrx(0): VESA VBE OEM Product Rev: 01.00
    (II) fglrx(0): ATI Video BIOS revision 9 or later detected
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 8, (OK)
    drmOpenByBusid: Searching for BusID PCI:1:0:0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 8, (OK)
    drmOpenByBusid: drmOpenMinor returns 8
    drmOpenByBusid: drmGetBusid reports PCI:1:0:0
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.51.3
    	ABI class: X.Org Server Extension, version 0.3
    (II) fglrx(0): Using adapter: 1:0.0.
    (II) fglrx(0): [FB] Find the MC FB aperturs range(MCFBBase = 0xc0000000, MCFBSize = 0x20000000)
    (--) fglrx(0): VideoRAM: 262144 kByte, Type: DDR4
    (II) fglrx(0): PCIE card detected
    (--) fglrx(0): Using per-process page tables (PPPT) as GART.
    (II) fglrx(0): board/chipset is supported by this driver (original ATI board)
    (II) Loading sub module "ddc"
    (II) LoadModule: "ddc"(II) Module "ddc" already built-in
    (II) fglrx(0): Connected Display1: DFP on secondary TMDS [tmds2i]
    (II) fglrx(0): Display1 EDID data ---------------------------
    (II) fglrx(0): Manufacturer: ENC  Model: 1687  Serial#: 0
    (II) fglrx(0): Year: 2003  Week: 30
    (II) fglrx(0): EDID Version: 1.2
    (II) fglrx(0): Digital Display Input
    (II) fglrx(0): Max H-Image Size [cm]: horiz.: 38  vert.: 30
    (II) fglrx(0): Gamma: 2.20
    (II) fglrx(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
    (II) fglrx(0): First detailed timing is preferred mode
    (II) fglrx(0): redX: 0.640 redY: 0.330   greenX: 0.300 greenY: 0.600
    (II) fglrx(0): blueX: 0.140 blueY: 0.100   whiteX: 0.313 whiteY: 0.329
    (II) fglrx(0): Supported VESA Video Modes:
    (II) fglrx(0): 720x400@70Hz
    (II) fglrx(0): 640x480@60Hz
    (II) fglrx(0): 800x600@60Hz
    (II) fglrx(0): 1024x768@60Hz
    (II) fglrx(0): Manufacturer's mask: 0
    (II) fglrx(0): Supported Future Video Modes:
    (II) fglrx(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
    (II) fglrx(0): Supported additional Video Mode:
    (II) fglrx(0): clock: 108.0 MHz   Image Size:  376 x 301 mm
    (II) fglrx(0): h_active: 1280  h_sync: 1328  h_sync_end 1440 h_blank_end 1688 h_border: 0
    (II) fglrx(0): v_active: 1024  v_sync: 1025  v_sync_end 1028 v_blanking: 1066 v_border: 0
    (II) fglrx(0): Serial No: 46716073
    (II) fglrx(0): Ranges: V min: 59  V max: 61 Hz, H min: 31  H max: 64 kHz, PixClock max 110 MHz
    (II) fglrx(0): Monitor name: L767
    (II) fglrx(0): EDID (in hex):
    (II) fglrx(0): 	00ffffffffffff0015c3871600000000
    (II) fglrx(0): 	1e0d010280261e78eaeee5a3544c9923
    (II) fglrx(0): 	195054a1080081800101010101010101
    (II) fglrx(0): 	010101010101302a009851002a403070
    (II) fglrx(0): 	1300782d1100001e000000ff00343637
    (II) fglrx(0): 	31363037330a20202020000000fd003b
    (II) fglrx(0): 	3d1f400b000a202020202020000000fc
    (II) fglrx(0): 	004c3736370a202020202020202000f8
    (II) fglrx(0): End of Display1 EDID data --------------------
    (WW) fglrx(0): Only one display is connnected,so single mode is enabled
    (EE) fglrx(0): PreInitDAL failed
    .
    Quote Originally Posted by Vighy View Post
    The second happens to me too here (with all versions of fglrx with all versions of Xorg and with all versions of the kernel but under 64bit)
    I started with suspend to disc this year...
    Quote Originally Posted by Vighy View Post
    so, what about this!?
    It's a bug not a feature

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •