Results 1 to 4 of 4

Thread: Dell 6400/e1505 + Slackware 12.1 + ati 8.6 + dual monitor = crash

  1. #1

    Default Dell 6400/e1505 + Slackware 12.1 + ati 8.6 + dual monitor = crash

    OK I've been running Slackware 12.1 on my Dell 6400/e1505 for some time now. I usually don't fiddle with settings if things work, I'm using computer at every day work (I'm a PHP coder) and stability is what I look for.
    Now, I want to add an external display to my laptop, configured it for dual monitors using the aticonfig utility + some tweaks I found googleing (disabled AIGLX & Composite).
    When I start X sometimes it crashes on start, sometimes it runs for a few minutes then it crashes, Xorg.0.log shows no errors, the only report I get is the "backtrace" :


    Code:
    Backtrace:
    0: X(xf86SigHandler+0x80) [0x80dbde0]
    1: [0xffffe400]
    2: /usr/lib/xorg/modules//glesx.so [0xb5485dd3]
    3: /usr/lib/xorg/modules//glesx.so [0xb548641f]
    4: /usr/lib/xorg/modules//glesx.so [0xb5485696]
    5: /usr/lib/xorg/modules//glesx.so(esutCreateBinaryProgram+0x35) [0xb54833b5]
    6: /usr/lib/xorg/modules//glesx.so [0xb547e686]
    7: /usr/lib/xorg/modules//glesx.so [0xb5481409]
    8: /usr/lib/xorg/modules//libxaa.so(XAAComposite+0x127) [0xb764d927]
    9: /usr/lib/xorg/modules//libxaa.so [0xb7669c38]
    10: X [0x816a037]
    11: X(CompositePicture+0x157) [0x8150a57]
    12: X [0x8156ab3]
    13: X [0x8153985]
    14: X [0x814700e]
    15: X(Dispatch+0x2cb) [0x808699b]
    16: X(main+0x496) [0x806ddb6]
    17: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7cec390]
    18: X(FontFileCompleteXLFD+0x20d) [0x806d0e1]


    If I start X with the 2nd monitor unplugged it runs without any problems.


    Dell 6400/e1505
    Ati Mobility X1400
    Slackware: 12.1
    Kernel version: 2.6.25.3
    Xorg: 7.0.98
    Ati driver: 8.6

  2. #2

    Default

    Any ideas anyone?

  3. #3
    Join Date
    Oct 2007
    Posts
    321

    Default

    the only fix is to wait until all of the dual monitor fixes are done, because 8.4 if you use dual monitor will spam the xorg log and cause some systems to become unstable.

  4. #4

    Default

    Yeah, I dropped the fglrx driver completely after mplayer is crashing X when tries to run, the error is somehow the same, so I'm gonna wait for better drivers.
    I'm currently using the "radeon" driver with no DRM, seems to work with both displays, any suggestions to use a different driver for my Radeon X1400 (mobile).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •