Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: A way to get 3d support on 3870x2?

  1. #1
    Join Date
    Jul 2008
    Posts
    17

    Default A way to get 3d support on 3870x2?

    I'm currently using the RadeonHD driver, and it works fine for 2d. I don't think there's any acceleration, although playing videos works 'all right'..

    But i can't find out if it's possible to get some kind of 3d acceleration.

    I'm pretty sure i read somewhere that you actually could, with just using one core on the card, but it seems i have missed HOW exactly to do it.

    So if anyone know where there is an 'easy' description on how to do it, or would just post one here, it'd be real nice

    I have also tried the official ATI driver, but i just can't get that to work at all..

  2. #2
    Join Date
    Aug 2007
    Posts
    6,683

    Default

    The usual hack is using:

    ChipID 0x9501

    in xorg.conf (Device section) and adding

    the correct id (950F) into the fglrxko_pci_ids.h file before compiling + installing the kernel module. You may have to try serveral drivers (maybe 8-3 or 8-4).

  3. #3
    Join Date
    Jul 2008
    Posts
    17

    Default

    Ok so i download one of the official ati drivers, unpak that somehow(i have forgotten how), edit 'fglrxko_pci_ids.h' that is in the dir of the extracted driver(?), and then edit the xorg.conf.

    How should it look in the xorg.conf? Just 'ChipID 0x9501' by itself with the {device} start/end?

    Pardon my noobness, it's VERY long since i last touched linux

  4. #4
    Join Date
    Aug 2007
    Posts
    6,683

    Default

    Which distro are you using?

  5. #5
    Join Date
    Jul 2008
    Posts
    17

    Default

    I'm using Ubuntu 8.4 as it seems to be the easiest to get started with....

  6. #6
    Join Date
    Jul 2008
    Posts
    17

    Default

    The usual hack is using:

    ChipID 0x9501

    in xorg.conf (Device section) and adding

    the correct id (950F) into the fglrxko_pci_ids.h file before compiling + installing the kernel module. You may have to try serveral drivers (maybe 8-3 or 8-4).
    "the correct id (950F) into the fglrxko_pci_ids.h"

    Where do i find this file, and how do i put in the correct id? Do i just edit the file(when found) with VI and put it in a list of ID's?

  7. #7
    Join Date
    Aug 2007
    Posts
    6,683

    Default

    How did you install the driver?

  8. #8
    Join Date
    Jul 2008
    Posts
    17

    Default

    By using "sudo ./ati-driver.....run"

    I've just installed it again and now i get a "white screen of death" when login in.

    I've logged in with the "safe xterm" right now and looking in the xorg.conf file. There's only the "identifier "configured video device""...

    Btw. i'm trying the 8.7 ati driver atm. I installed using the autoinstall mode.
    Last edited by GoBBLeS; 07-22-2008 at 07:37 AM.

  9. #9
    Join Date
    Aug 2007
    Posts
    6,683

    Default

    Best come to the IRC or let me login, it is a bit hard to explain.

  10. #10
    Join Date
    Jul 2008
    Posts
    17

    Default

    I just tried to build a Ubuntu specific package, just to try it out.

    It just creates a directory with alot of different installers, and none of them seems to actually install anything properly, so..blehh

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •