Results 1 to 5 of 5

Thread: Catalyst 8.7 crashes Xorg at startup on M76

  1. #1
    Join Date
    Dec 2007
    Location
    /dev/hell
    Posts
    297

    Default Catalyst 8.7 crashes Xorg at startup on M76

    As I pointed out in http://www.phoronix.com/forums/showp...5&postcount=12

    With this release Xorg hangs at startup. It seems to be distribution INdependent, and architecture INdependent since I tried both on:

    - x86_64 gentoo with kernel tuxonice-sources-2.6.25-r6
    and on
    - i686 Kubuntu Hardy directly from the liveCD (the new "supported" one )

    The chipset is M76 - Mobility Radeon HD2600 - 512MB of ram.

    for the lazy ones that don't want to click on the link, here the dump of Xorg

    Code:
    [...snip...]
    (**) fglrx(0): ATI GART size: 255 MB
    (II) fglrx(0): [pcie] 261120 kB allocated
    (II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 65536
    (**) fglrx(0): UseFastTLS=1
    (==) fglrx(0): BlockSignalsOnLock=1
    (II) fglrx(1): === [atiddxPreInit] === begin
    (EE) fglrx(1): Quitting secondary screen -- no monitor specified.
    (EE) fglrx(1): PreInit failed
    (II) fglrx(1): === [atiddxPreInit] === end
    
    Backtrace:
    0: /usr/bin/X(xf86SigHandler+0x6a) [0x49263a]
    1: /lib/libc.so.6 [0x7f9767b64da0]
    2: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxDriverEntPriv+0xf) [0x7f976592dcef]
    3: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxFreeScreen+0x2e) [0x7f9765932b8e]
    4: /usr/bin/X(xf86DeleteScreen+0x7e) [0x4a5ade]
    5: /usr/bin/X(InitOutput+0xa1f) [0x46c0bf]
    6: /usr/bin/X(main+0x2c6) [0x437256]
    7: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f9767b501d6]
    8: /usr/bin/X(FontFileCompleteXLFD+0x289) [0x4366f9]
    
    Fatal server error:
    Caught signal 11.  Server aborting
    This is not a minor bug.... since it prevents Xorg from starting at all!!!

  2. #2
    Join Date
    Dec 2007
    Location
    /dev/hell
    Posts
    297

    Default

    So nobody from AMD is interested in this case? I just wonder why it happens, since with other versions of the driver never happened something dramatic like this!

    If you ask me I will try with other versions of Xorg or what ever you want. ;-)
    (Xorg was 1.4.2 on gentoo and the stock one on ubuntu.)

  3. #3
    Join Date
    Dec 2007
    Location
    /dev/hell
    Posts
    297

    Default

    So nobody at AMD can tell me if this driver was tested with the Mobility Radeon HD2600 in house?

    since it crashes Xorg with a supported distro (ubuntu 8.04) on this chipset... so it's quite simple to reproduce the problem for you, ain't it?

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,285

    Default

    Don't know about this specific release - we rotate across a fairly big list of hardware platforms. There is a core set of hardware but the driver runs on literally thousands of different platforms and don't test on all of them. A lot of these problems are platform specific -- which laptop are you actually using ?

    Maybe a dumb question, but weren't your earlier posts about HD3xxx, or was it someone else who posted that the driver worked better on HD3xxx before we added Hd3xxx support ?

  5. #5
    Join Date
    Dec 2007
    Location
    /dev/hell
    Posts
    297

    Default

    Quote Originally Posted by bridgman View Post
    Don't know about this specific release - we rotate across a fairly big list of hardware platforms. There is a core set of hardware but the driver runs on literally thousands of different platforms and don't test on all of them. A lot of these problems are platform specific -- which laptop are you actually using ?

    Maybe a dumb question, but weren't your earlier posts about HD3xxx, or was it someone else who posted that the driver worked better on HD3xxx before we added Hd3xxx support ?
    well it was me, if it was about Mobility HD2xxx :-) I said it in 3 or 4 posts, because I felt ignored :-) since nobody answered... now I'm much more relaxed

    this is the pastebin of my atigetsysteminfo.sh:

    http://pastebin.com/fa57653

    shortly the laptop is an Asus Pro31Sa (Motherboard from F3Sa) you could get it from here, I think:

    Code:
    #
    ==========/proc/dri/0/biosversion (22:47)==========
    #
     
    #
    BIOS_CREATION_DATE="01/28/08,15:12:26"
    #
    BIOS_MSG="ASUS_F3Sa A12 M76 BIOS GDDR2 400m/500e ASID:A15201.011$                     "
    #
    BIOS_KIT_VERSION="BK-ATI VER010.054.000.000"
    Thanks Bridgman I hope my information will help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •