Results 1 to 4 of 4

Thread: Ati open drivers dont work on X1400?

  1. #1
    Join Date
    Nov 2006
    Posts
    72

    Default Ati open drivers dont work on X1400?

    Hello, I've always been using Ati's proprietary drivers, fglrx. I wanted to try AIGLX with the open source drivers. Well, I can't get my ATI Mobility Radeon X1400 recognized.
    Here's what i have in xorg.conf:
    Code:
    Section "Device"
    Identifier "ATI Mobility X1400" 
    Driver "radeon"
    BusID "PCI:1:0:0"
    Option "AccelMethod" "XAA"
    Option "AGPMode" "8"
    Option "GARTSize" "64"
    Option "EnablePageFlip" "1"
    Option "ColorTiling" "1"
    Option "XAANoOffscreenPixmaps" "true"
    EndSection
    This is what I get in Xorg.0.log:
    Code:
    (II) Primary Device is: PCI 01:00:0
    (EE) No devices detected.
    lspci -v:
    Code:
    01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400 (prog-if 00 [VGA])
            Subsystem: Dell Unknown device 2003
            Flags: bus master, fast devsel, latency 0, IRQ 16
            Memory at d0000000 (32-bit, prefetchable) [size=256M]
            I/O ports at ee00 [size=256]
            Memory at efdf0000 (32-bit, non-prefetchable) [size=64K]
            [virtual] Expansion ROM at efd00000 [disabled] [size=128K]
            Capabilities: [50] Power Management version 2
            Capabilities: [58] Express Legacy Endpoint IRQ 0
            Capabilities: [80] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
    I have enabled module support for radeon and drm in the kernel. I have debian sid with 2.6.20 self-compiled. What am I missing? Thanks

  2. #2

    Default

    You are missing that the X1k line is not supporetd by the open driver. There simply are no specs by ATI/AMD for that line upwards. The r300 drivers itself were decompiled fglrx drivers to at elast get some specs. The max of supported cards is something like X800. Just have a look at this page for some infos about the open drivers: http://dri.freedesktop.org/wiki/ATI?...HardwareVendor

  3. #3
    Join Date
    Nov 2006
    Posts
    72

    Default

    ah crap! i thought there was something like that going on. I tried google but couldn't find the exact info.
    Oh well.. Btw, is fglrx driver going to support AIGLX any time soon?

  4. #4
    Join Date
    Sep 2006
    Location
    PL
    Posts
    907

    Default

    it's not like that - the official open driver developer wrote X1*00 support, since his company was under a NDA agreement with ATI - he had the specs, it was easy to write the driver.

    but also because of the NDA he had to send the patches to ATI to have them reviewed, whether they don't break the NDA agreement.

    that was ~6 months ago. ATI didn't reply. so the X1*00 support is effectively blocked in the open drivers. that's very ironic, since the patch to the driver is composed of ~600 lines of code.

    R500 line (X1300 cards and upwards) is very different from <=R400 (X8*0 and below) cards. even 2d support is totally different - most fb drivers won't even initalize R500 cards properly - try using anything else than vesafb in kernel for frabebuffer console and all you'll get will be black screen or garbage on boot.
    Last edited by yoshi314; 02-18-2007 at 10:46 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •