O RLY? Yes, PhpBB is VERY insecure! Almost every months there's another hole somewhere. Just a few months ago 42,000+ forums were vulnerable to a serious exploit. Don't run it unless you want to get defaced or worse...