Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Linux Game Publishing domain sites "down" because of ISP woes...

  1. #21
    Join Date
    Oct 2006
    Location
    Israel
    Posts
    597

    Default

    Does bandit use the same soft-OpenAL as X3?
    I seem to be hitting some weird X3 only issues with sound that I cannot reproduce on other SDL based games (D3/Q4/ETQW, UT2K4) and other alsa applications.

    - Gilboa
    DEV: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX780, F20/x86_64, Dell U2711.
    SRV: Intel S5520SC, 2xX5680, 36GB, 4x2TB, GTX550, F20/x86_64, Dell U2412..
    BACK: Tyan Tempest i5400XT, 2xE5335, 8GB, 3x1.5TB, 9800GTX, F20/x86-64.
    LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F20/x86_64.

  2. #22
    Join Date
    May 2008
    Posts
    36

    Default

    Quote Originally Posted by Svartalf View Post
    There's probably going to be at least one more spin of a beta there- I've fixed a handful of sound playback issues and rendering issues (If you're one of the testers that logged a problem report, please do me the favor of re-trying your problems you reported and logging a note of thumbs-up or thumbs down on each so I can reverify I've caught your bug when it DOES come out... ) but there's still a few narfy rendering issues and the final sound issues remaining so there's at least ONE more beta before the RC one comes out most likely.
    Yep, I plan on doing that one we see another beta. I do remember some posting about sound issues, though I remember posting a bug as mine was a little different than others. I will provide updated feedback on that ... positive or negative.

  3. #23
    Join Date
    Jun 2006
    Posts
    3,046

    Default

    Quote Originally Posted by gilboa View Post
    Does bandit use the same soft-OpenAL as X3?
    I seem to be hitting some weird X3 only issues with sound that I cannot reproduce on other SDL based games (D3/Q4/ETQW, UT2K4) and other alsa applications.

    - Gilboa
    Not yet. Need to move the build environment over to it like X3 already has (The current beta is still using the OLD SI implementation which is a source of part of the sound issues) and clean up some issues with the video player lib's selection of sound APIs- once I do that, I should have most of the anomalous sound playback failures squared away and only be looking for cleanups for where it doesn't gracefully downgrade functionality when it has issues with things.

    I'm not tied to the mantis buglist for X3, so I don't know the nature of the bug- would you PM me what it was doing on sound? It might be the same set of problems and I can tip that team off when I get back into IRC here in another day or so...

  4. #24
    Join Date
    Jun 2006
    Posts
    3,046

    Default

    Quote Originally Posted by me262 View Post
    IIRC I think it goes like half a month or 3 before needing that check.

    Pining for the fjords... someone at LGP's a Monty Python fan... ^_^
    Heh... There's several someones that're that in the group, myself included...

    "...Bereft of life, it rests in peace, if you hadn't nailed it to the perch, it'd be pushing up the daises..."

    That was such a gem of a rant- and it's one of my favorite performances from Cleese.

  5. #25
    Join Date
    Oct 2006
    Location
    Israel
    Posts
    597

    Default

    Quote Originally Posted by Svartalf View Post
    I'm not tied to the mantis buglist for X3, so I don't know the nature of the bug- would you PM me what it was doing on sound? It might be the same set of problems and I can tip that team off when I get back into IRC here in another day or so...
    P.S. sent.
    Thanks again for taking the time to help,
    - Gilboa
    DEV: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB, GTX780, F20/x86_64, Dell U2711.
    SRV: Intel S5520SC, 2xX5680, 36GB, 4x2TB, GTX550, F20/x86_64, Dell U2412..
    BACK: Tyan Tempest i5400XT, 2xE5335, 8GB, 3x1.5TB, 9800GTX, F20/x86-64.
    LAP: ASUS N56VJ, i7-3630QM, 16GB, 1TB, 635M, F20/x86_64.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •