Results 1 to 3 of 3

Thread: direct rendering only as root

  1. #1
    Join Date
    Dec 2007
    Posts
    34

    Smile direct rendering only as root

    I have the latest nvidia driver installed 3d works and compiz but its a bit choppy.
    I noticed that direct rending is only available as root or failsafe

    I have checked file permissions of nvidia files ok

    checked etc/group file I am on video group. ok

    tried different drivers and envy direct rendering only for root or failsafe

    not sure what to do next if i run games as root rendering is really smooth but as a normal user its bad, frame rates seem ok but its choppy.

    Thanks for any help

    here's my xorg

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder57) Thu Jul 17 18:39:19 PDT 2008

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    RgbPath "/usr/X11R6/lib/X11/rgb"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 30.0 - 110.0
    VertRefresh 50.0 - 150.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

  2. #2
    Join Date
    Aug 2008
    Location
    California, USA
    Posts
    196

    Default

    Adding this might help:

    Code:
    Section "DRI"
        Mode 0666
    EndSection

  3. #3
    Join Date
    Dec 2007
    Posts
    34

    Default

    Quote Originally Posted by wswartzendruber View Post
    Adding this might help:

    Code:
    Section "DRI"
        Mode 0666
    EndSection
    Hi thanks but it's solved now, I'm not sure how but I manually installed the nvidia driver from the website and it seemed to solve my problems,
    I think the install process cleaned up some file permission issues.

    Thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •