Results 1 to 5 of 5

Thread: Asus Xonar DX

  1. #1
    Join Date
    Sep 2007
    Location
    Athens-Hellas
    Posts
    255

    Default Asus Xonar DX

    Hi guys!
    I 'd like to ask a question, I am interested in buying Xonar DX soundcard and today saw Michael's article about Xonar D1 card which is the same card with DX only with PCI connection and it is working with ALSA 1.0.18rc1...
    My PCI slots are full and I only have 2 PCI express free (why not use them and by the way I d like to see how small PCI express works!)

    Is Xonar DX also working with 1.0.18rc1 alsa?? Or PCI Express connection needs other drivers?

  2. #2
    Join Date
    Jun 2006
    Posts
    362

  3. #3
    Join Date
    Sep 2007
    Location
    Athens-Hellas
    Posts
    255

    Default

    Quote Originally Posted by Licaon View Post
    Thank you my friend! So I will only need to compile alsa 1.0.18rc1 packages for now and it will be recognized, correct?

    I currently use alsa 1.0.17 at opensuse 11 from provided upgrade repo multimedia:audio packages and kernel's alsa driver kmp package is version 1.0.16 daily updated.
    I cannot understand why they provide 1.0.16 driver package whereas all the others are 1.0.17 version... Does 1.0.17 driver need 2.6.26 kernel??
    Anyone knows?
    And furthermore can Xonar DX work with the alsa parts I currently have or it needs desperately 1.0.18rc1??

  4. #4
    Join Date
    Jun 2006
    Posts
    362

    Default

    > So I will only need to compile alsa 1.0.18rc1 packages for now
    > and it will be recognized, correct?
    no, support is in since 1.0.17 ( or kernel 2.6.26 ), so you have it already

    you can have the kernel ( with included ALSA modules ) + ALSA tools or any kernel + ALSA modules compiled to this kernel + ALSA tools

    eg:
    -kernel 2.6.25 + ALSA 1.0.17 ( compiled for 2.6.25 brings good module ) + ALSA 1.0.17 tools = it will work with Xonar DX
    -kernel 2.6.26 ( has ALSA good module inside )+ ALSA 1.0.16 tools = it will work with Xonar DX ( this is my setup )


    you don't need 1.0.18rc1

  5. #5
    Join Date
    Sep 2007
    Location
    Athens-Hellas
    Posts
    255

    Default

    Quote Originally Posted by Licaon View Post
    > So I will only need to compile alsa 1.0.18rc1 packages for now
    > and it will be recognized, correct?
    no, support is in since 1.0.17 ( or kernel 2.6.26 ), so you have it already

    you can have the kernel ( with included ALSA modules ) + ALSA tools or any kernel + ALSA modules compiled to this kernel + ALSA tools

    eg:
    -kernel 2.6.25 + ALSA 1.0.17 ( compiled for 2.6.25 brings good module ) + ALSA 1.0.17 tools = it will work with Xonar DX
    -kernel 2.6.26 ( has ALSA good module inside )+ ALSA 1.0.16 tools = it will work with Xonar DX ( this is my setup )


    you don't need 1.0.18rc1
    Really thank you for your lights my friend!!
    I will follow your instructions!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •