Results 1 to 6 of 6

Thread: radeonhd driver config

  1. #1
    Join Date
    Jun 2008
    Posts
    21

    Default radeonhd driver config

    Hi all.
    How to properly configure radeonhd driver?
    Overall performance is good but fullscreen video playback is slow. Any solution/ideas?

  2. #2
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,798

    Default

    The first thing that comes to mind is enabling EXA acceleration since XAA is the default on some chips. In the radeonhd driver section of xorg.conf:

    Option "AccelMethod" "exa"

    Not sure about this, but I *think* that AtomBIOS support is not on by default, in which case you can try if AtomBIOS works better for you with:

    Option "UseAtomBIOS" "true"

    Btw, what Radeon card are you using?

  3. #3
    Join Date
    Jun 2008
    Posts
    21

    Default

    card is HD 2400 pro AGP
    slackware linux 12.1

  4. #4
    Join Date
    Jun 2008
    Posts
    21

    Default

    Tried options you've said - no result=( fullscreen video is slow.

  5. #5
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    Also make sure you have the latest radeonhd code from git, since textured video support was only added very recently.

    EDIT - if you have an HD2400 then the problem is simply that we don't have video acceleration for your card yet, but we are working on it. For now, you are probably already using the -x11 output -- if so that is probably as good as it's going to get until we get some HW acceleration added. Shouldn't be long though...
    Last edited by bridgman; 08-27-2008 at 06:54 AM.

  6. #6
    Join Date
    Jun 2008
    Posts
    21

    Default

    Ok then, we are waiting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •