Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Catalyst 8.8 and poorer performance

  1. #11
    Join Date
    Jan 2008
    Posts
    294

    Default

    Quote Originally Posted by bridgman View Post
    For anyone seeing slower performance with 8.8 try the "nopat" boot option to disable the use of PAT and see if that helps.
    I wonder if there is more to it than just PAT.

    I just built a vanilla 2.6.26.3 and

    # CONFIG_X86_PAT is not set

    but I now see glitching in the ut2004 demo which does not happen with 8-8 on a 2.6.24.2 (whose config was used to build the 26.3).

  2. #12
    Join Date
    Aug 2008
    Posts
    8

    Default

    Tried the nopat option: little improvement, but still slower than 8-7

    glxgears:
    8-7: ~2100fps
    8-8: ~1500fps
    8-8(nopat): ~1680fps

    returned to 8-7 and got the 2100fps
    also 8-6 yeilded about 2300fps, but was pretty unusable, prior to 8-6 it was consistantly ~2000-2100fps

    I know glxgears isn't a true benchmark, but it works for comparing results on the same machine to some extent. Besides I can barely play ut2004 on 8-8 now the frame rate is so bad.

    As far as stability: 8-5 and 8-6 segfaulted on just about anything. 8-7 works nicely. 8-8 has crashed my system a couple of times (once on when switching a youtube video from fullscreen, and another time when playing around with gxine's visualations.)

    Using:
    Ubuntu 8.04 64bit
    2.6.24-21-generic #1 SMP Mon Aug 25 16:57:51 UTC 2008 x86_64 GNU/Linux
    Gigabyte GA-MA78GM-S2H: (3200 IGP)
    AMD AthlonX2 4850e
    4g ram

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •