Strange problem here: When I de-activate desktop effects in KDE 4.1 I end up with such severe graphic corruption that the box is practically unusable. As soon as I switch the effects on again, everything's just fine.

However, with Xfce it's the other way around: bad corruption when compositing enabled, while no problem at all if disabled.

My system: OpenSuse 11.0, KDE 4.1, Sapphire Radeon X1550-64 Bit PCIE (RV505).

The xorg.conf:

Code:
Section "ServerLayout"
	Identifier     "Layout[all]"
	Screen      0  "aticonfig-Screen[1]-0" 0 0
	InputDevice    "Keyboard[0]" "CoreKeyboard"
	InputDevice    "Mouse[1]" "CorePointer"
	Option	    "Clone" "off"
	Option	    "Xinerama" "off"
EndSection

Section "Files"
	InputDevices   "/dev/gpmdata"
	InputDevices   "/dev/input/mice"
	FontPath     "/usr/share/fonts/misc:unscaled"
	FontPath     "/usr/share/fonts/local"
	FontPath     "/usr/share/fonts/75dpi:unscaled"
	FontPath     "/usr/share/fonts/100dpi:unscaled"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/URW"
	FontPath     "/usr/share/fonts/Speedo"
	FontPath     "/usr/share/fonts/PEX"
	FontPath     "/usr/share/fonts/cyrillic"
	FontPath     "/usr/share/fonts/latin2/misc:unscaled"
	FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
	FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
	FontPath     "/usr/share/fonts/latin2/Type1"
	FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
	FontPath     "/usr/share/fonts/baekmuk:unscaled"
	FontPath     "/usr/share/fonts/japanese:unscaled"
	FontPath     "/usr/share/fonts/kwintv"
	FontPath     "/usr/share/fonts/truetype"
	FontPath     "/usr/share/fonts/uni:unscaled"
	FontPath     "/usr/share/fonts/CID"
	FontPath     "/usr/share/fonts/ucs/misc:unscaled"
	FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
	FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/misc:unscaled"
	FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/Type1"
	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
	FontPath     "/usr/share/fonts/xtest"
	FontPath     "/opt/kde3/share/fonts"
EndSection

Section "Module"
	Load  "dbe"
	Load  "type1"
	Load  "freetype"
	Load  "extmod"
	Load  "glx"
EndSection

Section "ServerFlags"
	Option	    "AllowMouseOpenFail" "on"
	Option	    "ZapWarning" "on"
EndSection

Section "InputDevice"
	Identifier  "Keyboard[0]"
	Driver      "kbd"
	Option	    "Protocol" "Standard"
	Option	    "XkbLayout" "de"
	Option	    "XkbModel" "microsoftpro"
	Option	    "XkbRules" "xfree86"
EndSection

Section "InputDevice"
	Identifier  "Mouse[1]"
	Driver      "mouse"
	Option	    "Buttons" "5"
	Option	    "Device" "/dev/input/mice"
	Option	    "Name" "Microsoft Wheel Mouse Optical"
	Option	    "Protocol" "explorerps/2"
	Option	    "Vendor" "Sysp"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "Modes"
	Identifier     "Modes[0]"
	ModeLine     "1024x768" 80.7 1024 1080 1192 1360 768 769 772 802
	ModeLine     "800x600" 48.9 800 840 920 1040 600 601 604 627
	ModeLine     "800x600" 45.5 800 840 920 1040 600 601 604 625
	ModeLine     "800x600" 42.1 800 840 920 1040 600 601 604 623
	ModeLine     "800x600" 38.2 800 832 912 1024 600 601 604 622
EndSection

Section "Monitor"
	Identifier   "Monitor[0]"
	VendorName   "NCI"
	ModelName    "NEC CI FT500"
	UseModes     "Modes[0]"
	DisplaySize  304	228
	HorizSync    30.0 - 60.0
	VertRefresh  43.0 - 75.0
	Option	    "DPMS"
	Option	    "PreferredMode" "1024x768"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[1]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "Device[0]"
	Driver      "fglrx"
	VendorName  "ATI"
	BoardName   "Radeon X1550 64-bit"
	Option	    "monitor-VGA_1" "Monitor[0]"
	BusID       "2:0:0"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[1]-0"
	Driver      "fglrx"
	Option	    "VideoOverlay" "off"
	Option	    "OpenGLOverlay" "off"
	Option	    "UseFastTLS" "1"
	Option	    "BackingStore" "on"
	Option	    "Textured2D" "on"
	Option	    "XAANoOffscreenPixmaps" "True"
	Option	    "TexturedXrender" "True"
	BusID       "PCI:2:0:0"
EndSection

Section "Screen"
	Identifier "Screen[0]"
	Device     "Device[0]"
	Monitor    "Monitor[0]"
	DefaultDepth     24
	SubSection "Display"
		Depth     15
		Modes    "1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes    "1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes    "1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes    "1024x768" "800x600"
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[1]-0"
	Device     "aticonfig-Device[1]-0"
	Monitor    "aticonfig-Monitor[1]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Group        "video"
	Mode         0666
EndSection

Section "Extensions"
	Option	    "Composite" "true"
	Option	    "RENDER" "true"
	Option	    "XVideo" "true"
EndSection
Since I work mostly with desktop-effects enabled, but am using Google-Earth a lot, I really need both modes working well.