Results 1 to 4 of 4

Thread: Intel X3100 performance TOO low.. is this normal?

  1. #1
    Join Date
    Mar 2007
    Location
    Recife, Brazil
    Posts
    5

    Default Intel X3100 performance TOO low.. is this normal?

    Hi,

    I've recently bought a laptop (Dell Inspiron 1525) with an integrated Intel X3100 card. I know that performance isn't the point of those cards, but it was just the one which fit in my financial possibilities.

    I've tested the card with the preinstalled Vista and it worked just as I was expecting. I get a not great, but usable frame rate in some simple software I use, like Celestia or Google Earth.

    The reason why I'm asking for help is: on Linux, this card performs AWFULLY! On the same program (like Celestia), I get ridiculous frame rates (like 1 - 10fps) instead of 40 - 50fps I get on Windows. Google Earth is also much slower. Direct rendering is working, and so is Compiz Fusion - I just have a clean Hardy install with all the current updates. But the card is simply much slower than in Windows.

    Is this the expected result on the current state of the drivers or I may have a problem? What could I try?

    I also tried Intrepid, but the result wasn't much better and I got many rendering errors in Celestia.

    (I have another computer on a Nvidia card, can't see noticeable perfomance difference on the softwares I've tested between Linux and Windows).

  2. #2
    Join Date
    Mar 2007
    Location
    Recife, Brazil
    Posts
    5

    Default

    Ahh, forgot to mention that I get those results with or without Compiz enabled

  3. #3
    Join Date
    Aug 2008
    Posts
    116

    Default

    I'm no expert on Intel cards, but it is possible that Intel has been focusing on the functionality, and in the future optimizations will be made to improve performance. I know that in the AMD camp a similar approach is taken to driver development of new gfx cards.

    If I'm correct, all you have to do is hang in there for the moment, and if the desktop really becomes unusable, just turn off compiz

  4. #4
    Join Date
    Aug 2008
    Location
    California, USA
    Posts
    196

    Default

    I found my old GMA 950 to have about 1/5 the performance under Linux as opposed to Windows. I think that was using xf86-video-intel-2.4.0.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •