Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Open-Source Radeon Driver Improvements

  1. #11
    Join Date
    Nov 2007
    Posts
    1,353

    Default

    Quote Originally Posted by dungeon View Post
    @duby229

    Read this. I think you can also safely revert back this patch to make your 3D work again, but maybe it is already fixed in 7.1 release and you can tried that first.
    Yeah I think that's it. After reading the guru's, I'm not sure what I can do except wait. I can try to reverse that patch, but I have no idea how to do it. I'll just wait it out and till it gets fixed in master then I'll just resync and reinstall.

  2. #12
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,543

    Default

    The key point from the link seems to be :

    Long story short: Mesa 7.1 requires xserver > 1.4.99.906
    Backing out that specific commit makes Mesa work with slightly older X servers (say 1.4.99.905) but it seems that picking up the very latest X server is the real answer. The commit in question had a corresponding commit in X server so you need both for things to work.

    Haven't actually tried it or anything though...

  3. #13
    Join Date
    Feb 2008
    Posts
    1,233

    Default

    Yes, yes, krh was yesterday applied fix for this and that means... LSS: xserver must be from git.

  4. #14
    Join Date
    Nov 2007
    Posts
    1,353

    Default

    Quote Originally Posted by dungeon View Post
    Yes, yes, krh was yesterday applied fix for this and that means... LSS: xserver must be from git.
    I've been trying to rebuild the xserver for a few weeks now, but so far I've had no luck at all. Every single time I try it craps out at the same spot.

    Code:
    ../doltcompile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include -I../hw/xfree86/os-support -I../hw/xfree86/os-support/bus -I../hw/xfree86/common -I../hw/xfree86/dri -I../hw/xfree86/dri2 -I../mi   -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/freetype2 -I/usr/include/pixman-1 -I/usr/include/hal -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include    -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow  -I../miext/damage -I../render -I../randr -I../fb -I/usr/include/drm -I/usr/include/X11/dri -DXFree86Server -D__GLX_ALIGN64 -O2 -pipe -march=k8 -MT indirect_dispatch_swap.lo -MD -MP -MF .deps/indirect_dispatch_swap.Tpo -c -o indirect_dispatch_swap.lo indirect_dispatch_swap.c
    ../doltcompile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include -I../hw/xfree86/os-support -I../hw/xfree86/os-support/bus -I../hw/xfree86/common -I../hw/xfree86/dri -I../hw/xfree86/dri2 -I../mi   -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/freetype2 -I/usr/include/pixman-1 -I/usr/include/hal -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include    -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow  -I../miext/damage -I../render -I../randr -I../fb -I/usr/include/drm -I/usr/include/X11/dri -DXFree86Server -D__GLX_ALIGN64 -O2 -pipe -march=k8 -MT indirect_reqsize.lo -MD -MP -MF .deps/indirect_reqsize.Tpo -c -o indirect_reqsize.lo indirect_reqsize.c
    In file included from indirect_dispatch.c:40:
    glapitable.h:812: error: expected declaration specifiers or '...' before 'GLint64EXT'
    glapitable.h:813: error: expected declaration specifiers or '...' before 'GLuint64EXT'
    indirect_dispatch.c: In function '__glXDisp_TexSubImage1D':
    indirect_dispatch.c:2976: warning: cast to pointer from integer of different size
    indirect_dispatch.c: In function '__glXDisp_TexSubImage2D':
    indirect_dispatch.c:3000: warning: cast to pointer from integer of different size
    indirect_dispatch.c: In function '__glXDisp_TexImage3D':
    indirect_dispatch.c:3748: warning: cast to pointer from integer of different size
    indirect_dispatch.c: In function '__glXDisp_TexSubImage3D':
    indirect_dispatch.c:3777: warning: cast to pointer from integer of different size
    make[1]: *** [indirect_dispatch.lo] Error 1
    make[1]: *** Waiting for unfinished jobs....
    In file included from indirect_dispatch_swap.c:40:
    glapitable.h:812: error: expected declaration specifiers or '...' before 'GLint64EXT'
    glapitable.h:813: error: expected declaration specifiers or '...' before 'GLuint64EXT'
    indirect_dispatch_swap.c: In function '__glXDispSwap_TexSubImage1D':
    indirect_dispatch_swap.c:3096: warning: cast to pointer from integer of different size
    indirect_dispatch_swap.c: In function '__glXDispSwap_TexSubImage2D':
    indirect_dispatch_swap.c:3120: warning: cast to pointer from integer of different size
    indirect_dispatch_swap.c: In function '__glXDispSwap_TexImage3D':
    indirect_dispatch_swap.c:3884: warning: cast to pointer from integer of different size
    indirect_dispatch_swap.c: In function '__glXDispSwap_TexSubImage3D':
    indirect_dispatch_swap.c:3913: warning: cast to pointer from integer of different size
    make[1]: *** [indirect_dispatch_swap.lo] Error 1
    mv -f .deps/indirect_reqsize.Tpo .deps/indirect_reqsize.Plo
    make[1]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-9999/work/xorg-server-9999/glx'
    make: *** [all-recursive] Error 1
    Any idea on how to get around this error when compiling the xserver?

  5. #15
    Join Date
    Jul 2008
    Location
    Wrocław/Poland
    Posts
    37

    Default

    duby229
    Check whether you have the latest (git) x11-proto packages and mesa from git installed.
    I have a problem with building xorg-server from git as well, but the problem is with osdep.h header (OPEN_MAX macrodefinition - it needs manual tweak to compile).
    Besides maybe this forum is not the best place to discuss problems with Gentoo ebuilds.
    Last edited by reavertm; 08-28-2008 at 01:51 PM.

  6. #16
    Join Date
    Nov 2007
    Posts
    1,353

    Default

    Quote Originally Posted by reavertm View Post
    duby229
    Check whether you have the latest (git) x11-proto packages and mesa from git installed.
    I have a problem with building xorg-server from git as well, but the problem is with osdep.h header (OPEN_MAX macrodefinition - it needs manual tweak to compile).
    Besides maybe this forum is not the best place to discuss problems with Gentoo ebuilds.
    Yeah I've got both of thos packages installed from git... I'm not saying that it's not gentoo's fault, but I highly doubt it... And this is a forum where many of the people who work on these projects gather and discuss these topics.. I mean if this isnt the place to ask for help,. then where is?

    EDIT: I've created a thread on the gentoo forums. (I'm gonna hold off on creating a bug just yet) So please feel free to post either here or there any suggestions you may have.
    Last edited by duby229; 08-28-2008 at 07:55 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •