Results 1 to 3 of 3

Thread: About Quake 4 SMP article - you got it wrong

  1. #1
    Join Date
    Jul 2006
    Posts
    20

    Default About Quake 4 SMP article - you got it wrong

    Hi,

    I can't believe I believed your article for so long! :-)

    Quake 4 SMP is NOT virtually non-existent on Linux. The reason you got no performance increase was for several reasons:

    1. You must run the benchmark with the video settings turned as low as possible, else the game becomes video card limited, and the speed of the cpu (or the number of cpus) becomes irrelavent. These days with GPUs doing most of the calculations, this is a factor. (This explains why your CPU usage was maxing out at 66%).

    2. YOU MUST ENABLE THE SMP OPTION IN THE GAME MENUS EVEN WHEN RUNNING WITH THE './quake4-smp' COMMAND.

    I visited the page for some unremembered reason, and saw that, unlike in Windows, the smp option is dimmed in normal './quake4' mode, but not in './quake4-smp' mode. It is off on both versions by default. This got me thinking: what if I set it to on, and benchmarked?

    At high-res, I got identical results with both uniprocessor mode (UP mode), or smp mode.

    Then, like I described, I set the video mode to 640x480, turned off high-quality effects under 'advanced', and set the quality to low quality. Then I turned on the smp flag. Then I quit to the command line.

    Then I ran timedemoquit with in both UP and SMP modes, with the 2 different commands (quake4 and quake4-smp)

    Here are the results:

    ./quake4:
    UP: 2458 frames rendered in 32.1 seconds = 76.5 fps

    ./quake4-smp WITH r_useSMP set to "1":
    SMP: 2458 frames rendered in 23.3 seconds = 105.6 fps

    OK, so no 87% increase, but that might be because I demo'ed using a demo I recorded that stressed the GPU particularly hard, and even at low res, the CPU was a limiting factor. I'll try to find/create a very gpu non-stressing demo and try again.

    And, as I said (and just like in the Windows benchmarks) benchmarking at the video resolution/quality I run at (1280x1024, quincunx AA, 16xaniso, high quality, geforce 7600gt, opteron 165 OC @ 2520MHz) SMP or UP modes are identical.

    So, it DOES work! You just have to do right! :-) :-) :-)

    Could I suggest you update your article with a note saying why you couldn't get it to work, and post a note to to www.linuxgames.com of the success? Thanks.

    (I'm surprised TTimo didn't chime in before this - TTimo, you do read the Linux community forums, don't you? :-) )
    Last edited by ayqazi; 07-22-2006 at 10:33 PM.

  2. #2

    Default

    ayqazi,

    Since that article was published, we have indeed achieved success on a great deal of the SMP systems and the Quake 4 v1.2.1 patch, while a few multi-core systems seem to have a less than significant impact. However, these results continue to be smaller than those percentages provided by id Software, and is less significant than some numbers reported by Windows users.

    We had tried to reach TTimo for comment prior to posting that article; however, he had failed to get back with us. We will try to update the article to make it clearer, and sorry for any confusion.

  3. #3
    Join Date
    Jul 2006
    Posts
    20

    Default

    I hope you understand my post was meant to have a humorous tone about it - I hope nobody took offense at it or anything (it's always difficult to kid around on the 'net, people always take things the wrong way).

    Thanks for the reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •