Results 1 to 3 of 3

Thread: About Quake 4 SMP article - you got it wrong

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Jul 2006

    Default About Quake 4 SMP article - you got it wrong


    I can't believe I believed your article for so long! :-)

    Quake 4 SMP is NOT virtually non-existent on Linux. The reason you got no performance increase was for several reasons:

    1. You must run the benchmark with the video settings turned as low as possible, else the game becomes video card limited, and the speed of the cpu (or the number of cpus) becomes irrelavent. These days with GPUs doing most of the calculations, this is a factor. (This explains why your CPU usage was maxing out at 66%).


    I visited the page for some unremembered reason, and saw that, unlike in Windows, the smp option is dimmed in normal './quake4' mode, but not in './quake4-smp' mode. It is off on both versions by default. This got me thinking: what if I set it to on, and benchmarked?

    At high-res, I got identical results with both uniprocessor mode (UP mode), or smp mode.

    Then, like I described, I set the video mode to 640x480, turned off high-quality effects under 'advanced', and set the quality to low quality. Then I turned on the smp flag. Then I quit to the command line.

    Then I ran timedemoquit with in both UP and SMP modes, with the 2 different commands (quake4 and quake4-smp)

    Here are the results:

    UP: 2458 frames rendered in 32.1 seconds = 76.5 fps

    ./quake4-smp WITH r_useSMP set to "1":
    SMP: 2458 frames rendered in 23.3 seconds = 105.6 fps

    OK, so no 87% increase, but that might be because I demo'ed using a demo I recorded that stressed the GPU particularly hard, and even at low res, the CPU was a limiting factor. I'll try to find/create a very gpu non-stressing demo and try again.

    And, as I said (and just like in the Windows benchmarks) benchmarking at the video resolution/quality I run at (1280x1024, quincunx AA, 16xaniso, high quality, geforce 7600gt, opteron 165 OC @ 2520MHz) SMP or UP modes are identical.

    So, it DOES work! You just have to do right! :-) :-) :-)

    Could I suggest you update your article with a note saying why you couldn't get it to work, and post a note to to of the success? Thanks.

    (I'm surprised TTimo didn't chime in before this - TTimo, you do read the Linux community forums, don't you? :-) )
    Last edited by ayqazi; 07-22-2006 at 09:33 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts