Results 1 to 2 of 2

Thread: Quake 4 Ultra Quality performance problem with 8.8

  1. #1
    Join Date
    Sep 2008
    Posts
    2

    Default Quake 4 Ultra Quality performance problem with 8.8

    I decided to give the 4870 and AMD/ATI a second chance. I bought a 4870 when the 8.6 drivers were out and it was not a pleasant experience. It either hard hung when X started and eventually the system rebooted, or I got a solid black screen, and remote connections in showed the X log looking as if everything was fine.

    So, I took the card back. Decided to give it a second shot with the 8.8 drivers and so far, things appear to be working. I haven't tried out compiz yet, but various 3d games work fine. ET: QuakeWars, Doom3, UT2004, PlanetPenguin Racer, armagetronad, all so far so good.

    Only major problem has been Quake4. I can't run at Ultra quality without it slowing to < 1fps. I mean, it is really really slow. High quality or lower, it works great. I noticed that Q4 doesn't pick up the 512MB on the card, and only detected 64MB, so I bumped up the videoRam configuration directives to 512 and it didn't make a difference. Is there some trick to running Q4 in Ultra quality with the ATI drivers?

    It just worked with the nvidia binary drivers with my 8800GTS 640.

    Initial benchmarks has the 4870 running significantly slower than my 8800GTS 640. 110fps for 1920x1200 ultra quality in doom3 vs 120-130 for my older nvidia card. I expected that though, as the most "advanced" game that works under Linux is ET:QW and that gets plenty usable framerates. I have to reboot to Windows to play most of my other games any ways, and on there, the 4870 absolutely screams.

    FYI, I did try going back to 8.7 and 8.6 to see if it would work, since it appears that phoronix was able to run Q4 ultra for their benchmarks. 8.7 and 8.6 both have the hang/reboot and black screen behavior I described above.

    Also, I'm running on Gentoo x86_64 with the 2.6.25-gentoo-r7 kernel with 4GB physical RAM.
    Last edited by dopey; 09-02-2008 at 10:04 AM.

  2. #2
    Join Date
    Sep 2008
    Posts
    2

    Default

    Did some more playing and I am having some better results. Using quake4-smp (I have a Core 2 Quad Q6600 CPU running at stock clock), I now get ~70fps at 1920x1200 @ ultra.

    This is a bit slower than I anticipated as I should be in the ~100 range, but it's better. Quite odd that quake4-smp vs quake4 has such a huge difference with the ATI card though. With my old 8800GTS the two benchmarked identically.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •