Page 3 of 12 FirstFirst 12345 ... LastLast
Results 21 to 30 of 118

Thread: AMD Catalyst 8.9 Gets WINE Fix, RandR 1.2 Support

  1. #21
    Join Date
    Feb 2008
    Posts
    3

    Default

    Mhhh last ati drivers include new features but they come with more problems.
    I use only linux and the only app 3d that I use is quake3arena.
    So, with 8.7 I've no problems with q3 (also if there is problems with wine, fixed with this realase, and blender); but with 8.8 I have problems with mouse movements on q3, and with 8.9 now the mouse don't works into the game, and X crash.
    I'm using Debian Lenny realase in an Acer Aspire 5672 with ati raden mobility X1400.
    Now I ordered a new pc with nvidia card, but I hope AMD/ATI will come the best choice for linux users with the future opensource driver.
    Bye

  2. #22
    Join Date
    Apr 2008
    Posts
    127

    Default OpenGL 3.0 support close?

    I saw that the Windows 8.9 version already supports some extensions for OpenGL 3.0 support (they call it `OpenGL 3.0 support - Phase 1'). Lets hope these new features will soon also arrive for Linux!

  3. #23
    Join Date
    Jun 2008
    Location
    Groningen, The Netherlands
    Posts
    42

    Default

    Well, if I have to choose between xserver 1.5 support or opengl 3 I'd take xserver 1.5 support any day!

  4. #24
    Join Date
    Sep 2008
    Posts
    16

    Default

    this release does have improvement against some issue's that came along but an new one of course came up.

    In this case the issue I'm having with this new release is in compiz fusion the alpha blur effect is become the equivalent of the saturation effect.

    So if i have alpha blur enabled just about all my menu's become gray instead of having the blur effect like i had set them to have.

    Another issue is I was being logged out after 3 seconds from these drivers, but that was only after i had logged in and out a few times which in most cases i never do.

    Those are the only ones that are new for me this release.

    Running an IGP 1200 Xpress ( rs690 ) [512 MiB memory shared to this IGP], the rest i don't think matters but AMD64x2 cpu, 2 GiB RAM, and Gigabyte Motherboard on Ubuntu 8.04. If you need more info just say so.

    Actually it's xorg thats crashing nor me being logged out it has the same effect as Ctrl+Alt+Backspace though once it happens once it continuously happens afterwards. This is not limited to repeated logging in and out (thats the easy way to cause this fault) it can happen at random times too.
    Last edited by TheWind; 09-18-2008 at 09:57 AM.

  5. #25
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    364

    Default

    Wow, just read the phoronix article.
    I'm really looking forward to the upcomming 8.10 driver, hoping I'll get XServer 1.5 support on my birthday

    EDIT: @TheWind:
    I'm experiencing the same problem. This doesn't occur with focus blur though...
    Last edited by NeoBrain; 09-18-2008 at 08:29 AM.

  6. #26
    Join Date
    Sep 2008
    Posts
    9

    Default changelog

    Interesting things about the changelog/new features:

    I first learned of the ATI Proprietary Linux Driver Releases news feed, which states:

    Driver version: 8.532

    NEW FEATURES:
    (1) Production support for Red Flag DT6SP1 and OpenSUSE 11

    ISSUES RESOLVED: (1) Desktop corruption when using full screen Wine application. (2) Compilation issues against Linux kernel 2.6.26. (3) HDMI Audio support on Radeon HD 3100/3200 products. (4) X fails after driver install for Radeon HD 4870 and FireGL V7700. (5) Choppy playback during video playback. (6) Fatal error while restarting X, after resolution change in amdcccle. (7) Segmentation fault when running textured video.

    https://a248.e.akamai.net/f/674/9206..._89_linux.html
    However, on the page that the feed links to, there is no mention of these issues...

  7. #27
    Join Date
    Apr 2008
    Posts
    127

    Default

    Quote Originally Posted by StefanHamminga View Post
    Well, if I have to choose between xserver 1.5 support or opengl 3 I'd take xserver 1.5 support any day!
    You are absolutely right, for most people xserver 1.5 is far more important then OpenGL 3.0. I am using Ubuntu 8.04 with the default 8.6.24-19, so currently I don't have any specific wishes for other kernel/xserver/xorg support (although I might upgrade to Ubuntu 8.10 when it arrives, so that would mean I also need support for all these things).

    Quote Originally Posted by NeoBrain View Post
    Wow, just read the phoronix article.
    I'm really looking forward to the upcomming 8.10 driver, hoping I'll get XServer 1.5 support on my birthday

    EDIT: @TheWind:
    I'm experiencing the same problem. This doesn't occur with focus blur though...
    Hah, if you present it like this: who knows I get a nice birthday present too (14th October, that is probably a bit to early for the next release).

  8. #28
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    364

    Default

    Quote Originally Posted by Heiko View Post
    Hah, if you present it like this: who knows I get a nice birthday present too (14th October, that is probably a bit to early for the next release).
    15th October for me, still way too early for a feature release ;-) I expect it about the 23rd.

    Apart from that, I don't care much about OGL 3.0 either as long as there are no apps using it.

  9. #29
    Join Date
    Apr 2008
    Location
    A Coruņa (Spain)
    Posts
    100

    Default

    The only difference I've noticed wrt 8.8 is that now in amdcccle I cannot override the application settings for Antialiasing and Anisotropic filtering (everything is disabled). I can change Adaptive Antialiasing, Mipmap detail and "More Settings", though.

    Anyone else? HD3850 here.

  10. #30
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    364

    Default

    Quote Originally Posted by Fran View Post
    The only difference I've noticed wrt 8.8 is that now in amdcccle I cannot override the application settings for Antialiasing and Anisotropic filtering (everything is disabled). I can change Adaptive Antialiasing, Mipmap detail and "More Settings", though.

    Anyone else? HD3850 here.
    amdcccle segfaults for me... I'm not using it too often anyways

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •