Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: A Year Later, X-Fi Drivers Still Horrific

Hybrid View

  1. #1
    Join Date
    Jan 2007
    Posts
    15,645

    Default A Year Later, X-Fi Drivers Still Horrific

    Phoronix: A Year Later, X-Fi Drivers Still Horrific

    After Creative Labs Duped Linux For Vista, it was just a year ago that they had released their X-Fi Linux driver. That initial driver in 2007 had only supported 64-bit Linux, wasn't targeted at newer versions of GCC, and had a whole host of other problems...

    http://www.phoronix.com/vr.php?view=Njc3Mg

  2. #2
    Join Date
    Feb 2007
    Posts
    83

    Default

    But you get sound with the binary blob, right?

  3. #3
    Join Date
    Aug 2007
    Location
    Norway
    Posts
    146

    Default

    Don't buy newer generation Creative sound cards if you're planning on using Linux. Just don't. There are other high-end options that I'm sure are better supported by ALSA. For casual/simple audio needs, the integrated HD audio chipsets on today's motherboards are getting pretty good, and they usually work fairly well with ALSA.

  4. #4
    Join Date
    Feb 2007
    Posts
    83

    Default

    I got a Audigy4 ATM its pretty good...but I'd really like a x-fi xtremegamer, which is supposed to be great for gaming on windows. My only worry is if I dont get any sound on linux with it...

    EDIT: If anyone wants to trade I'm all for it

  5. #5
    Join Date
    Aug 2007
    Location
    Norway
    Posts
    146

    Default

    Quote Originally Posted by conholster View Post
    I got a Audigy4 ATM its pretty good...but I'd really like a x-fi xtremegamer, which is supposed to be great for gaming on windows. My only worry is if I dont get any sound on linux with it...

    EDIT: If anyone wants to trade I'm all for it
    Put in both sound cards if you've got an available slot .

  6. #6
    Join Date
    Feb 2007
    Posts
    83

    Default

    Quote Originally Posted by oyvind View Post
    Put in both sound cards if you've got an available slot .
    OMG!!! Will that work? If so I could connect my 5.1 on one card and headset into the other!

  7. #7
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,801

    Default

    Open Sound System 4 should have proper X-Fi drivers.

  8. #8
    Join Date
    Jun 2007
    Location
    The intarwebs
    Posts
    385

    Default

    Well, now that Atheros went open, nVidia released a new driver, and Dell got broadcom to get on it... Does this make Creative The Most Troublesome Holdout?

  9. #9
    Join Date
    Apr 2007
    Posts
    372

    Default

    any brilliant programmer who could reverse engineer, the windows driver in order to make a GPL driver?

    cheers maybe with that i could buy a soundblaster card again...

  10. #10
    Join Date
    Mar 2008
    Posts
    579

    Default

    just a quick note for everyone:

    at moment, alsa cannot manage which default sound card to use while the kernel is booting. read alsa wiki for more information about it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •