Results 1 to 9 of 9

Thread: FC7 Test 3 & Ati Mobility Radeon 9600/9700 Series (help needed)

  1. #1
    Join Date
    Apr 2007
    Posts
    9

    Default FC7 Test 3 & Ati Mobility Radeon 9600/9700 Series (help needed)

    Hello guys, I am new on these forums. I came here because I was googling for this and found Michael's blog somewhere.
    I have just installed Cedega and it says that I need a graphics driver. Then I realized I had to install these:
    • qt-devel
    • kernel-devel
    • kernel-headers


    But when installing the ATI driver like Michael said in his thread, it returns this:
    Code:
    ==================================================
     ATI Technologies Linux Driver Installer/Packager 
    ==================================================
    Generating package: Fedora/F7
    Please install an appropriate Linux kernel module build package.
    The package(s) you need are likely kernel-devel and/or kernel-headers.
    If you've compiled a custom kernel, make sure /usr/src/linux exists
    and the source tree matches the currently running kernel.
    I tried making a symbolic link:
    Code:
    ln -s /usr/src/kernels/2.6* /usr/src/linux
    But it still returns the same error.
    What could be the problem?

  2. #2

    Default

    Did you compile the kernel yourself or using a stock RPM kernel?

  3. #3
    Join Date
    Apr 2007
    Posts
    9

    Default

    I did like you.I downloaded the newest linux graphics driver. I followed the guide like a slave. I linked to it above.

    EDIT: Oh, now I understand.. No, I just installed the latest FC7 Test 3 CD, then I used yum to download the kernels.
    Last edited by Ralle; 04-11-2007 at 07:26 AM.

  4. #4

    Default

    Then you need to do

    yum install kernel-headers kernel-devel

  5. #5
    Join Date
    Apr 2007
    Posts
    9

    Default

    I just did that, and it still does returns the same error (written above).
    I wrote this:
    ./ati-installer.sh 8.33.6 --buildpkg Fedora/F7
    But the driver isn't actually version 8.33.6, can that be the problem?

    EDIT: I tried writing in the current version number. Still same error.

  6. #6

    Default

    Then change 8.33.6 to whatever version you are using

  7. #7
    Join Date
    Apr 2007
    Posts
    9

    Default

    I am using 8.35.5. Still same error.

    fglrx_6_8_0-8.35.5-1.i386.rpm

    I am thinking about just switching to FC6. This is my only problem though.
    Last edited by Ralle; 04-11-2007 at 09:53 AM.

  8. #8

    Default

    So is it still erroring you out on the kernel source? Otherwise it should present you with four RPMs and just not one. Be aware there is a Xorg bug with Rawhide unless you downgrade the Xorg server to F7T2 area.

  9. #9
    Join Date
    Apr 2007
    Posts
    9

    Default

    yes, same error.

    I do not wish to work with this. I am installing FC6. It should be my Personal Computer, not for testing

    Lovely website btw!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •