Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: AIGLX: When???

Hybrid View

  1. #1
    Join Date
    Mar 2007
    Location
    São Paulo, Brazil
    Posts
    74

    Exclamation AIGLX: When???

    Hi,

    I'm new at this forum, but I've been reading here for a while now.

    Does anyone have any clue on when will we (ATI users) be able to use AIGLX? (Actually I think the right question would be: WILL we be able to use AIGLX?)

    Every ATI driver release is a disappointment... No significant performance improvements NOR important features like the ones needed by AIGLX.

    From what I've read in Phoronix latest driver review, it's probable that we won't see aiglx for months... I surely hope this is wrong.

    Is there anything we can do to make ATI/AMD wake up and do something? The bug has been filled on their bugzilla, but nothing seems to happen. They should a least give some feedback so we can know what is the current status on this issue.

    What do you guys think about this?

  2. #2

    Default

    Nicolas,

    The support you are looking for is months away, but should be out this calendar year (or so I believe).

    All YOU can do to try to get AMD to wake up more is to contact their AIBs and other partners (i.e. ASUS, Abit, etc...) and tell them specifically you want to see better drivers. That is what needs to be done instead of contacting AMD directly.

  3. #3
    Join Date
    Mar 2007
    Location
    São Paulo, Brazil
    Posts
    74

    Default

    Thanks for the info.

    It's a shame they don't implement such an important (and probably not so hard) feature on their driver. Instead they implement UNACCELERATED support for newer video cards.

    After waiting for months for this, I would definitelly think twice before buying another computer that uses a ATI video card.

    Unfortunatelly I can't upgrade to a nVidia card right now because I'm on a notebook, so I would have to buy a whole new notebook.

    I really hope AMD does something about this.

    Just my 2c....

    Thanks again...

  4. #4
    Join Date
    Sep 2006
    Location
    PL
    Posts
    916

    Default

    one thing that really escapes my comprehension is :

    missing gl extensions are provided bu software fallback in mesa, right? so that's not really the case about not supporting aiglx. when you load x.org with fglrx driver you get an aiglx error - "falling back to software rendering". even so, you cannot start beryl even using that software rendering with fglrx and aiglx.

    what i fail to understand is - what is so different between xgl and aiglx that one works with ati and the second one does not?

    can somebody clearly explain - what is the actual problem with fglrx and aiglx? because missing 3d extensions don't seem to be the case.

  5. #5

  6. #6
    Join Date
    Sep 2006
    Location
    PL
    Posts
    916

    Default

    nice read. that doesn't answer my question, though.

    why does xgl work with fglrx and aiglx does not?

  7. #7

    Default

    Quote Originally Posted by yoshi314 View Post
    nice read. that doesn't answer my question, though.

    why does xgl work with fglrx and aiglx does not?

    Wasn't meant to answer that question. The very basic reason that XGL works is because XGL does not rely upon GLX_EXT_texture_from_pixmap where as AIGLX does.

  8. #8
    Join Date
    Sep 2006
    Location
    PL
    Posts
    916

    Default

    fedora site states that fglrx uses "ancient" DRI API and that's why it does not work with aiglx. if that is the truth - that's one neglected thing.

    i always thought that missing extensions are provided as software (mesa) fallbacks.

  9. #9
    Join Date
    Mar 2007
    Location
    São Paulo, Brazil
    Posts
    74

    Default

    Nice article... I just wish ATI/AMD wakes up!

    If I had a desktop computer I would upgrade my videocard to a nVidia model, but I can't do this on my notebook.

    6 months is a lot of time for ONE driver feature.

  10. #10
    Join Date
    Apr 2007
    Posts
    5

    Default My X1650 is not doing OpenGL

    I'm pretty new at Linux. I just upgraded my machine with an ATI X1650 Pro. I planned to switch over to Linux, but I have had problem after problem with the ATI drivers. I tried Ubuntu Edgy, Feisty Fawn, Sabayon, finally to conclude that it's because of the ATI drivers that I can't get desktop acceleration to work.
    Now I also can not run Google Earth or Sketchup, or Cedega, because OpenGL support is not detected.
    In the xorg.0.log I get messages that DRI is not working, and I get Mesa driver reported by fglrxinfo.
    I'm so frustrated!
    Just to be sure: is it really because of the ATI drivers, or am I doing something wrong?
    All help appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •