Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: 780g issues

  1. #1
    Join Date
    Oct 2008
    Posts
    4

    Question 780g issues

    Howdy cowboys,

    i bought a 780g motherboard to watch TV (dvb-t) and the like. I get permanent video stutter with this fglrx driver. The last one that was working somehow was catalyst 8.7.1.1, but switching users via kdm or logging out froze the system with this version.
    What can i do to watch non hd videos and logout with a 780g and a phenom 9885?

    To be honest I am *very* pissed. I read that the stutter thing is related to some kernel thing, at least 2.6.27 didn't solve anything(nopat kernel option didn't do anything as well), and remember the catalyst update brought up the stutter issues (And hell no, i can't go back as I *need* to switch users, mkay?)

    It would be soooooo great if amd/ati could get their shit together on at least releasing a binary blob with basic functionallity - I think I paid for this.

    maybe it's a config issue after all, but i don't think so, tried too much in the last few months since i have this quite useless chip.
    If somebody has this things working with 780g *please* post your config along with an xorg.conf and driver versions and the like

    radeonhd doesn't work for me, although i wasn't able to try the new version.
    Please help me if it is a fault of mine, or otherwise, get the driver working for fucks sake!

    i use x86_64, archlinux for more info ask, if it helps, please..
    Last edited by wallace; 10-14-2008 at 01:15 PM.

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,571

    Default

    kernel version ? If you are using 2.6.26 or higher you may have the PAT conflict and need to disable PAT in your boot string.

  3. #3
    Join Date
    Jul 2008
    Posts
    208

    Default

    Try earlier suggestion.

    For what its worth, I have 780g and am using slackware 12.1, kernel 2.6.25.16. I'm currently using catalyst 8.9 but for 780g 8.5 still works better with mythtv. The relevant portions of my xorg.conf are:

    Code:
    Section "ServerLayout"
    	Identifier     "Simple Layout"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    	InputDevice    "Mouse1" "CorePointer"
    	InputDevice    "Keyboard1" "CoreKeyboard"
    EndSection
    
    Section "Module"
    	Load  "dbe"  	# Double buffer extension
    	SubSection "extmod"
    		Option	    "omit xfree86-dga"   # don't initialise the DGA extension
    	EndSubSection
    	Load  "type1"
    	Load  "freetype"
    	Load  "glx"
    	Load  "dri"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
            Option "VideoOverlay" "off"
            Option "TexturedVideo" "on"
            Option "OpenGLOverlay" "off"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    By the way. If I click on video, xine opens and stutters, using opengl. I don't think this happened with catalyst 8.5 but can't really remember. But if I change video from opengl to xv or xshm, xine does not stutter. Give that a try.

  4. #4
    Join Date
    Dec 2007
    Posts
    145

    Default A simple solution that you will not like

    I have a Gigabyte GA-MA780GM-S2H in my media PC, I had reasonably smooth playback just using X11 under fglrx, but not a sharp picture. The moment I activated xv the picture improved but troubles started such as not shutting down and HDTV just being lines. I tried everything but now await Catalyst 8.10, but not with any confidence.

    My solution was to buy a cheap Nvidia pcie board - an 8400GS for around $35 and now it all works. An Nvidia 6200 is good enough and they are even cheaper.

    I consider using this "cheat" a temporary solution until the catalyst driver matures. My main computer had a Radeon HD3450, now not used, but I had so many issues as to make it useless. The biggy was once the display went to sleep it would not wake up again and it too would not play back HDTV content. Luckily that machine has onboard Intel graphics. It is a sad day when low level onboard graphics are used in preference.

    I have high hopes for Catalyst 8.10, I hope they do not let us down.

  5. #5
    Join Date
    Dec 2007
    Posts
    145

    Default Another Option

    If you have no need for 3D then try using the open source radeon or radeonhd driver, just make sure that it is a new version of those drivers. They can provide reasonable xv playback, just not compiz.

    Update - I just reinstalled my HD3450 and compiled radeonhd from the git and there is no xv support for the RV600 series so out it comes again. The X11 video is jerky. Other 2d functionality seems good I await the next update to this driver as it does show promise.
    Last edited by grege; 10-15-2008 at 06:23 AM.

  6. #6
    Join Date
    Oct 2008
    Posts
    4

    Default

    first of all, thank you so much for your help

    @Bridgeman, adding nopat to the kernel line didn't help unfortunately.

    Not using opengl as a playback solves the issues although i got tearing when i quickly tried.
    I really have high expectations of 8.10 too, hopefully it will be a stable one.
    cheers.

  7. #7
    Join Date
    Dec 2007
    Posts
    145

    Default 8.10 report

    I removed the Nvidia from my media machine and installed Catalyst 8.10.
    Gigabyte GA-MA78GM-S2H
    Ubuntu Intrepid beta
    DVico FusionHDTV

    Standard def digital TV works fine. Xvid palyback is good with an occassional line. The TV goes to sleep and wakes up as it should. I do not have a blu-ray so I cannot test that.

    HDTV is an issue. I can get it to show up using xv but jerky, but then HDTV can nuke X and require a restart. Still working on that issue, but overall working good.

    Update: Watching TV through Kaffeine works by setting the Video to xshm and then HD TV works fine. With Me-TV that is not an option and nothing works reliably for HD, though SD digital TV works fine (BTW mine is PAL - NTSC may be different). Still the occasional line accross the display but barely noticeable. All in all still not as good as using an Nvidia board but functional enough. XvMc is supposed to be included but Kaffeine will not let you select it.

    ps on my desktop using HD3450 and HDTV from USB stick runs fine with same driver on Debian Sid.
    Last edited by grege; 10-16-2008 at 07:09 PM.

  8. #8
    Join Date
    Oct 2008
    Posts
    5

    Default

    Quote Originally Posted by forum1793 View Post
    Try earlier suggestion.

    For what its worth, I have 780g and am using slackware 12.1, kernel 2.6.25.16. I'm currently using catalyst 8.9 but for 780g 8.5 still works better with mythtv. The relevant portions of my xorg.conf are:

    Code:
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
            Option "VideoOverlay" "off"
            Option "TexturedVideo" "on"
            Option "OpenGLOverlay" "off"
    EndSection
    By the way. If I click on video, xine opens and stutters, using opengl. I don't think this happened with catalyst 8.5 but can't really remember. But if I change video from opengl to xv or xshm, xine does not stutter. Give that a try.
    I notice that you have both VideoOverlay and OpenGLOverlay to "off". I assume that as a result you have no XV excelleration. For me, mythtv doesn't work without XV enabled. Would is be possible to set VideoOverlay to On for driver 8.5? Or can these same configs be used for 8.9 or 8.10?

    Hans

  9. #9
    Join Date
    Dec 2007
    Posts
    145

    Default Xv

    Catalyst now uses "TexturedVideo" to activte Xv "VideoOverlay" has no effect.

    With catalyst 8.10 you do not need anything in xorg.conf other than the driver line. To test whether you have xv just open a terminal and run xvinfo and you should get something like :-

    $ xvinfo
    X-Video Extension version 2.2
    screen #0
    Adaptor #0: "ATI Radeon AVIVO Video"
    number of ports: 4
    port base: 131
    operations supported: PutImage
    supported visuals:
    depth 24, visualID 0x23
    depth 24, visualID 0x24

    and much more

    Also run fglrxinfo and glxinfo to ensure all is running properly.


    Quote Originally Posted by hansch View Post
    I notice that you have both VideoOverlay and OpenGLOverlay to "off". I assume that as a result you have no XV excelleration. For me, mythtv doesn't work without XV enabled. Would is be possible to set VideoOverlay to On for driver 8.5? Or can these same configs be used for 8.9 or 8.10?

    Hans
    Last edited by grege; 10-17-2008 at 09:12 AM.

  10. #10
    Join Date
    Oct 2008
    Posts
    4

    Default all right then..

    well...after not getting dri working i deleted /etc/ati and reinstalled xorg-server and the catalyst stuff. after that i at least get direct rendering. xv works too. But wait, this is *no* success story.

    Video stutter is still there, opengl playback or xv, it does not matter.(Only the severeness of stutter)
    Second big issue is that i can't use kde4 anymore, as it seams that it uses some feature that is inherently broken in the driver since the dark ages. I can't remember how i fixed it back then, so anybody has an idea? Here are some screenshots where you can see what the bug looks like.

    Last time i played with render options i think, but i can't get it working this time.

    my xorg.conf: (this used to work for me until i tried to fix video stutter, and i came a long way since then, 130 reboots included... and a moustache..)

    Code:
    Section "Device"
    
    #	Driver "radeonhd"
    #	Driver "vesa"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	Option	    "Texture2D" "on"
    	Option	    "TexturedXrender" "on"
    	Option	    "UseFastTLS" "1"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "TexturedVideo" "on"
    	Option	    "TexturedVideoSync" "off"
    	Option	    "RenderAccel" "True"
    	Option	    "DRI" "true"
    	BusID       "PCI:1:5:0"
    #	Option "VideoOverlay" "off"
    #	Option "TexturedVideo" "off"
    #	Option "OpenGLOverlay" "off"
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "Enable"
    	Option	    "XVideo" "Enable" #enable
    	Option	    "RENDER" "1"
    	Option	    "DAMAGE" "Enable" #enable
    EndSection
    I tried almost all enable/disable combos of the options, nothing helped to give me kde4 back.

    gnome "works" though, meaning, no artifacts.

    If anybody has any suggestions, that'd be great. Otherwise I think I'll go back to the vesa driver, I can have stutter free video with this one (but no VT switching, i get rainbow colors then)

    Btw, AMD should really do itself a favour and stop the "we support linux and free software" talks, that's just bullshit.
    Linux support is not duplicating atombios in a driver for a year or what and get *nothing* to work on a widespread chip. Fire your marketing monkeys and start DOING SOME REAL WORK! Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •