Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: help needed for Mythtv and 3450

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Posts
    51

    Default help needed for Mythtv and 3xxx

    I've got a 3450 and use it mostly for watching TV.
    I can't use the radeonhd drivers because they don't support Xv, which means the picture doesn't display properly on mythtv.

    This means I'm stuck with fglrx.

    I currently use 8.5, which more or less works with Myth, but it has a few serious issues.
    1) Switching channels in LiveTV doesn't work properly if I switch between channels that use different video types (i.e. BBC1 to ITV1) - I get a garbled display and have to exit TV and then go back in to see the picture properly. But at least it doesn't crash!
    2) I can't run more than one X session (so no XP-style "switch user" functionality). Any attempts crash my PC hard.
    3) I can't restart X (PC crashes), but I can logout a user and then login again (wahay! very useful...)
    4) I can only watch certain video formats, as some crash my PC. And I can't use xine, because it crashes my PC, so I have to use totem instead. vlc just crashes if I try to use it.
    Bit of a theme here.

    For the record, I used to have a 5 year old Matrox card which worked fine with all of the above in the same PC and the same OS (debian testing) but I gave it away and "upgraded" to the 3450 because I thought I'd be able to use it for HD video. How I wish I hadn't bothered...

    I've just tried 8.9 but it doesn't work with Myth at all - I just get a corrupt display, which persists for a few seconds when I exit Myth before suddenly sorting itself out. i.e. I can see a corrupt view of the desktop which is messed up in the same way as Myth is, and then suddenly everything looks good again.
    I haven't checked whether the other problems I have are fixed by 8.9 - frankly it's irrelevant if I can't watch TV.

    So does anyone have any suggestions? Anyone with a 3450 who isn't having the problems I'm having? It'd be nice if it turned out to just be a config problem, but I'm not holding out much hope.

    I'm strongly tempted to just throw it in the bin and get an Nvidia instead, but I'd rather see it actually working.
    Points 1-4 above are the only things I care about - 3D acceleration would be nice, but if it doesn't work, it really doesn't matter to me.
    Last edited by duffster; 10-16-2008 at 02:24 PM.

  2. #2
    Join Date
    Jun 2008
    Posts
    51

    Default

    So no response from 3450 owners.

    Anyone with a 3xxx got any ideas?

  3. #3
    Join Date
    Jan 2008
    Posts
    177

    Default

    I've been planning to get MythTV installed, but haven't yet. My laptop has an HD3450 and it seems to work fine with Xv using the new 8.10 driver.
    At least, vlc and mplayer can play DivX and such on it.

  4. #4
    Join Date
    Jan 2008
    Posts
    294

    Default

    Haven't tried Myth on my 3850, I do have a tv card but it's in a headless server box and I don't think myth would suit the setup.

    AIUI mplayer should work with with v4l stuff and mplayer is OK for me.

    If the Myth player allows maybe you could try using x11 instead of xv - more work for the Cpu doing colour space, but the GPU still gets to do the scaling.

  5. #5
    Join Date
    Jun 2008
    Posts
    51

    Default 8.10 has same problem

    So I tried 8.10, but it has the same problem.

    Then I remembered that this was the reason I was still using 8.5 - I had this exact same problem when I tried 8.6 and 8.7 (and I hadn't had time to try 8.8). So this problem has existed for 5 releases now.

    I searched back through the archives and found this thread:
    http://www.phoronix.com/forums/showthread.php?t=10940

    which contains a workaround to get Myth to work (and also shows I'm far from the only one who is seeing this). Basically, the workaround requires starting Mythtv with a nonstandard resolution e.g. 1280x1025. Presumably there's some modeline problem going on when using fullscreen openGL?

    I'm getting the impression that this issue isn't a priority for ATI.

    So I can at least use 8.10 now, but from my point of view I don't think it actually fixes any of my problems. Certainly my channel changing problem still exists, and as I've only just installed 8.10 I don't know if any of my other issues are fixed, or whether there are any other new problems introduced.

    I can't help but feel this is another long-term problem that fglrx is never going to fix. (Feel free to comment on this, ATI!).

    Anyone got any further information on this?
    Last edited by duffster; 10-19-2008 at 04:53 PM.

  6. #6
    Join Date
    Jul 2008
    Posts
    314

    Default

    I think it's a pretty common problem, but I haven't noticed it on a HD4850 so I don't know if there's any workarounds, other than trying 8.10 :/

  7. #7
    Join Date
    Jun 2008
    Posts
    51

    Default

    So, now that I'm using 8.10, issue 3 is fixed, but irritatingly not issue 2. ATI have posted about this in these forums in the past, and seem to think that it's not an issue because no-one uses more than one X session. Errrm, actually a lot of people do...
    radeonhd does this fine, but can't play video so not really an option to swap.
    issue 1 is still the same, and issue 4 is partially improved - I seem to be able to watch stuff with vlc, but xine still crashes my PC when playing certain videos. No idea why, it doesn't seem to be the video format that causes it.

    In fact the only improvement I've seen over the last 6 months is being able to restart X without a hard crash, whilst running 2 Xservers is apparently a step too far (despite the fact I've been able to do that with every other video card I've owned in the last 10 years).

    Not enormously impressed...

    ATI - perhaps you should concentrate on fixing all the showstoppers before you spend time enabling more features? Building on shaky foundations is not really the best plan.
    Last edited by duffster; 10-19-2008 at 04:51 PM.

  8. #8
    Join Date
    Jun 2008
    Posts
    51

    Default

    So, 8.12 and no improvement.

    I'm buying an Nvidia card for my other computer. I was going to stick with ATI but there's no end in sight to any of the problems. Pity...

  9. #9
    Join Date
    Aug 2009
    Posts
    1

    Default re: watch tv


  10. #10
    Join Date
    Jun 2008
    Posts
    51

    Default

    This is a linux forum. Your crappy windoze trojans will have no effect here...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •