Results 1 to 9 of 9

Thread: How to speed up etqw

  1. #1
    Join Date
    Jun 2008
    Posts
    10

    Default How to speed up etqw

    UPDATE

    It's look like the etqw-rthread work faster now... maybe nvidia 177.80 make a difference

    Code:
    '/usr/local/games/etqw/etqw-rthread' +set com_allowConsole 1 +seta com_unlock_timingMethod "1" +seta com_unlockFPS "1"  +seta com_unlock_maxfps "90" +seta com_videoRam "256" +seta r_useThreadedRenderer "2"
    in 1280x1024/Normal/AF8x/all_set reach now constantly 40-80 FPS during online play (in start menu I have still 30FPS )
    It is highly recommended to set cpu scheme to performance level
    and V-SYNC off

    My system debian-amd64 sid / NVIDIA GeForce 7800GT 256MB / Opteron 185 / 2GB RAM

    czarnyckm



    Obsolete

    Hi

    I just discovered how to speed up etqw. It looks like it doesn't use it own libSDL:

    Code:
    # ldd /usr/local/games/etqw/etqw.x86
            linux-gate.so.1 =>  (0xffffe000)
            libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0xf7eb8000)
    Here should be a symbolic link :

    Code:
    ln -s /usr/local/games/etqw/libSDL-1.2.id.so.0 /usr/local/games/etqw/libSDL-1.2.so.0
    and a change in the start script (etqw) from:

    Code:
    export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:."
    to:

    Code:
    export LD_LIBRARY_PATH=".:$LD_LIBRARY_PATH"

    after that etqw started with command:

    Code:
    '/usr/local/games/etqw/etqw' +set com_allowConsole 1 +seta com_unlock_timingMethod "1" +seta com_unlockFPS "1"  +seta com_unlock_maxfps "90" +seta com_videoRam "256"
    in 1280x1024/Normal/AF8x/all_set reach now constantly 90-100 FPS during online play (in start menu I have still 30FPS )
    It is highly recommended to set cpu scheme to performance level.

    My system debian-amd64 sid / NVIDIA GeForce 7800GT 256MB / Opteron 185 / 2GB RAM
    Last edited by czarnyckm; 10-18-2008 at 04:52 PM.

  2. #2
    Join Date
    Aug 2007
    Posts
    6,610

    Default

    Usually you don't need to change the startup script as the LD_LIBRARY_PATH is empty by default and the dirs are stored in /etc/ld.so.conf - on newer distros this includes all conf files from /etc/ld.so.conf.d. Also often it is better when the system wide files are used.

  3. #3
    Join Date
    Jun 2008
    Posts
    10

    Default

    Quote Originally Posted by Kano View Post
    Usually you don't need to change the startup script as the LD_LIBRARY_PATH is empty by default and the dirs are stored in /etc/ld.so.conf - on newer distros this includes all conf files from /etc/ld.so.conf.d. Also often it is better when the system wide files are used.
    Etqw must use it's own patched libSDL version in place of the standard one to reach performance increase.
    BTW to reach the standard version performance level there are no changes needed...
    Last edited by czarnyckm; 10-18-2008 at 07:28 AM.

  4. #4
    Join Date
    Nov 2007
    Posts
    297

    Default

    Quote Originally Posted by czarnyckm View Post
    Etqw must use it's own patched libSDL version in place of the standard one to reach performance increase.
    BTW to reach the standard version performance level there are no changes needed...
    *sigh*
    etqw ships with 2 linux binaries

    1) etqw.x86
    2) etqw-rthread.x86

    the 1st
    Code:
    ldd etqw.x86 | grep libSDL
    	libSDL-1.2.so.0 => /usr/lib32/libSDL-1.2.so.0 (0xf7f65000)
    Uses the system shared library. THIS version of the client is single-threaded

    the 2nd
    [code]
    ldd etqw-rthread.x86 | grep libSDL
    libSDL-1.2.id.so.0 => not found[/quote]
    is statically linked against an id patched version of libSDL. They had to patch libSDL because libSDL cannot do multithreaded (needed for threaded_renderer). They released the patched to libSDL to include in some later version

    The 1st should use the system libSDL, the 2nd *needs* to use the id libSDL and enable the cvar threaded_renderer

    there is no sekrit performance boost



    THEY also ship two bash scripts that LD_LIBRARY_PATH to etqw home directory to ensure the id's libSDL is loaded.

  5. #5
    Join Date
    Dec 2007
    Posts
    107

    Default

    So the only way to really speed the game up is using Windows or stronger hardware, then? Realtime kernels did not help my computer.

  6. #6
    Join Date
    Jun 2008
    Posts
    10

    Default

    Quote Originally Posted by marakaid View Post
    So the only way to really speed the game up is using Windows or stronger hardware, then? Realtime kernels did not help my computer.
    Did you tried? On my system it run so fast as quake4-smp now.
    Last edited by czarnyckm; 10-18-2008 at 09:32 AM.

  7. #7
    Join Date
    Jun 2008
    Posts
    10

    Default

    Quote Originally Posted by Naib View Post
    *sigh*
    Uses the system shared library. THIS version of the client is single-threaded

    the 2nd
    [code]
    ldd etqw-rthread.x86 | grep libSDL
    libSDL-1.2.id.so.0 => not found
    is statically linked against an id patched version of libSDL. They had to patch libSDL because libSDL cannot do multithreaded (needed for threaded_renderer). They released the patched to libSDL to include in some later version

    The 1st should use the system libSDL, the 2nd *needs* to use the id libSDL and enable the cvar threaded_renderer

    there is no sekrit performance boost



    THEY also ship two bash scripts that LD_LIBRARY_PATH to etqw home directory to ensure the id's libSDL is loaded.
    The etqw-rthread.x86 on my system start one thread only and work at 60FPS.

    The etqw.x86 start many threads and work with libSDL-1.2.id.so.0 at 90-100FPS. Before had I 30-60FPS only
    Last edited by czarnyckm; 10-18-2008 at 10:16 AM.

  8. #8
    Join Date
    Dec 2007
    Posts
    107

    Unhappy

    I have tried your trick and it does not change performance in my computer; It's a pity having to lower graphics options and still get less performance and more fps drops than Windows with max quality settings.

  9. #9
    Join Date
    Jun 2008
    Posts
    10

    Default

    Quote Originally Posted by Naib View Post
    *sigh*
    etqw ships with 2 linux binaries

    1) etqw.x86
    2) etqw-rthread.x86

    the 1st
    Code:
    ldd etqw.x86 | grep libSDL
    	libSDL-1.2.so.0 => /usr/lib32/libSDL-1.2.so.0 (0xf7f65000)
    Uses the system shared library. THIS version of the client is single-threaded

    the 2nd
    [code]
    ldd etqw-rthread.x86 | grep libSDL
    libSDL-1.2.id.so.0 => not found
    is statically linked against an id patched version of libSDL. They had to patch libSDL because libSDL cannot do multithreaded (needed for threaded_renderer). They released the patched to libSDL to include in some later version

    The 1st should use the system libSDL, the 2nd *needs* to use the id libSDL and enable the cvar threaded_renderer

    there is no sekrit performance boost



    THEY also ship two bash scripts that LD_LIBRARY_PATH to etqw home directory to ensure the id's libSDL is loaded.
    You're rhigt.

    I have tested on empty servers before... sorry about that

    But on full ones I have observed that etqw-rthread work faster now

    Code:
    '/usr/local/games/etqw/etqw-rthread' +set com_allowConsole 1 +seta com_unlock_timingMethod "1" +seta com_unlockFPS "1"  +seta com_unlock_maxfps "90" +seta com_videoRam "256" +seta r_useThreadedRenderer "2"
    Last edited by czarnyckm; 10-18-2008 at 02:10 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •