Results 1 to 2 of 2

Thread: Dell Precision 670: POST Test failure after restart from Red Hat 9.0

  1. #1
    Join Date
    Feb 2007
    Location
    Troy
    Posts
    8

    Default Dell Precision 670: POST Test failure after restart from Red Hat 9.0

    I am being paid to get some software working on a Dell Precision 670 workstation using a dual-boot config between Windows and Red Hat 9.0 (yeah, I wanted to use something newer, but the contract requires me to use RH9 for this project much to my dismay). Here are the system specs:

    Dual Xeon processors (3.0GHz or 3.2...don't remember which)
    4gb RAM
    40gb IDE hard drive (Linux drive)
    Quadro FX 4400

    Anyway, to make the ancient Linux distro see half the hardware (including the network card and USB), I had to roll out a compile of a newer version of the 2.4 kernel (2.4.33.6). After lengthy configuration (over a dozen recompiles) and headache, the system saw my stuff. I got the program running, and it looked like I was good to go.

    However, the problem I am having now is that the computer is failing the POST test when I restart the computer out of Linux. The beep code indicates a "DRAM Refresh Error" of some sort. I have never seen this happen restarting from Windows -- only from Linux. I have absolutely no idea what could cause this to happen, but the only thing I can really do to make the computer start up again is unplug it, wait about a minute, and then cold-boot it. My best guess is that something in the Linux kernel isn't cleaning up nicely (I had to use a couple things in the kernel labelled "Experimental" to get USB working properly) and corrupting something before giving up control of the computer to the BIOS.

    Have any of you guys ever seen a computer fail to POST from a restart? If so, do you have any suggestions on how to fix it? It's a really cryptic problem.

  2. #2

    Default

    Had you tried the 2.4.34.1 kernel? That would be my only possible suggestion off hand. I've never come across that problem before, but none of my machines use the 2.4 kernel any longer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •