Results 1 to 9 of 9

Thread: mouse crazy with enemy territory Linux

Hybrid View

  1. #1

    Default mouse crazy with enemy territory Linux

    Hi,

    I've installed ET on Opensuse 11-x64
    My mouse works well in KDE4

    When i launch ET, my mouse goes crazy and the pointer moves randomly in any directions.

    Anyone has experienced this before? how to fix this?

    Thx

    PS: i'm a linux newbie

  2. #2
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,582

    Default

    Quote Originally Posted by naindejardin View Post
    Hi,

    I've installed ET on Opensuse 11-x64
    My mouse works well in KDE4

    When i launch ET, my mouse goes crazy and the pointer moves randomly in any directions.

    Anyone has experienced this before? how to fix this?

    Thx

    PS: i'm a linux newbie
    Sounds like your mouse is using evdev. SDL and evdev don't like each other much. Go into your xorg.conf (located in /etc/X11) and find the mouse section. Try replacing it with:

    Code:
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "12"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Logitech USB Gaming Mouse"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    Post your complete xorg.conf if you want me to double check it before applying the changes.

  3. #3

    Default

    cat /etc/X11/xorg.conf
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-10-01T22:46:27+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [SaX2] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    InputDevice "Mouse[3]" "SendCoreEvents"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "dbe"
    Load "type1"
    Load "freetype"
    Load "extmod"
    Load "glx"
    Load "dri"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    Option "AllowMouseOpenFail" "on"
    Option "IgnoreABI" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "fr"
    Option "XkbModel" "pc102"
    Option "XkbOptions" "caps:shiftlock"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "evdev"
    Option "InputFashion" "Mouse"
    Option "Name" "Logitech Gaming Mouse"
    Option "Pass" "3"
    Option "Vendor" "Sysp"
    Option "evBits" "+1-2"
    Option "keyBits" "~272-287"
    Option "relBits" "~0-2 ~6 ~8"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[3]"
    Driver "mouse"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "ImPS/2 Generic Wheel Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    BusID "PCI:6:0:0"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

  4. #4
    Join Date
    Jul 2008
    Posts
    314

    Default

    BTW, if you look at what deanjo's done, the config for your Logitech mouse is now gone. I've got a G5 (and had the same problem with the evdev driver), and although the "mouse" driver works without any problems in games, the tilt function on the scroll wheel don't work at all with the Logitech mouse.

  5. #5
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,582

    Default

    Quote Originally Posted by grantek View Post
    BTW, if you look at what deanjo's done, the config for your Logitech mouse is now gone. I've got a G5 (and had the same problem with the evdev driver), and although the "mouse" driver works without any problems in games, the tilt function on the scroll wheel don't work at all with the Logitech mouse.
    Yes, that is true, less of two evils I guess. Personally I never used the side scroll on the wheel anyways. The bug wa submitted to SDL quite some time ago but still has received no attention.

    http://bugzilla.libsdl.org/show_bug.cgi?id=617
    Last edited by deanjo; 10-26-2008 at 06:07 PM.

  6. #6
    Join Date
    Jul 2008
    Posts
    314

    Default

    Quote Originally Posted by deanjo View Post
    Yes, that is true, less of two evils I guess. Personally I never used the side scroll on the wheel anyways. The bug wa submitted to SDL quite some time ago but still has received no attention.
    Annoyingly, the only useful place I can think of to use the tilt buttons is in games (quick selection of items).

    I wonder what it'd take to get tilt button support in "mouse"? I have no idea what the difference is between the two drivers, but you'd think they'd know about each other.

  7. #7
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,582

    Default

    Try replacing it with this xorg.conf

    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-10-01T22:46:27+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [SaX2] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    EndSection
    
    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection
    
    Section "Module"
    Load "dbe"
    Load "type1"
    Load "freetype"
    Load "extmod"
    Load "glx"
    Load "dri"
    EndSection
    
    Section "ServerFlags"
    Option "AIGLX" "on"
    Option "AllowMouseOpenFail" "on"
    Option "IgnoreABI" "on"
    Option "ZapWarning" "on"
    EndSection
    
    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "fr"
    Option "XkbModel" "pc102"
    Option "XkbOptions" "caps:shiftlock"
    Option "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "12"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Logitech USB Gaming Mouse"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    Section "Modes"
    Identifier "Modes[0]"
    EndSection
    
    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection
    
    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    BusID "PCI:6:0:0"
    EndSection
    
    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection
    
    Section "DRI"
    Group "video"
    Mode 0660
    EndSection
    Then of course log out and log back in or reboot.

  8. #8
    Join Date
    Jul 2008
    Posts
    314

    Default

    Hmm - I just played ETQW after upgrading my Ubuntu system to Intrepid (ie. Xserver 1.5, HAL configuration of devices as opposed to xorg.conf) - I didn't have any weird mouse problems but the tilt buttons worked. Looking through the X logs, it's picked up the evdev driver and doesn't seem to be conflicting with SDL

  9. #9
    Join Date
    Oct 2007
    Posts
    16

    Default

    Quote Originally Posted by grantek View Post
    Hmm - I just played ETQW after upgrading my Ubuntu system to Intrepid (ie. Xserver 1.5, HAL configuration of devices as opposed to xorg.conf) - I didn't have any weird mouse problems but the tilt buttons worked. Looking through the X logs, it's picked up the evdev driver and doesn't seem to be conflicting with SDL
    That's because newer games such as ET:QW and Quake 4 don't have any issues with the evdev driver. I don't know why, or what's different about them, something about the SDL using what iD calls "raw mouse input". But original ET and Doom 3 are basically unplayable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •