Results 1 to 5 of 5

Thread: Black screen on startup

  1. #1
    Join Date
    Nov 2008
    Posts
    3

    Default Black screen on startup

    Hi all,

    I am trying to use the ATI drivers on a 690G based board (MSI K9AGM3), but after apparently installing okay I just get a black screen on startup.

    The end of my xorg log is as follows:

    Code:
    	[28] -1	0	0x000001f0 - 0x000001f7 (0x8) IX[B]
    	[29] -1	0	0x000001f0 - 0x000001f0 (0x1) IX[B]
    	[30] -1	0	0x000001f0 - 0x000001f7 (0x8) IX[B]
    	[31] -1	0	0x00000b00 - 0x00000b0f (0x10) IX[B]
    	[32] -1	0	0x00008000 - 0x0000800f (0x10) IX[B]
    	[33] -1	0	0x00009000 - 0x00009003 (0x4) IX[B]
    	[34] -1	0	0x0000a000 - 0x0000a007 (0x8) IX[B]
    	[35] -1	0	0x0000b000 - 0x0000b003 (0x4) IX[B]
    	[36] -1	0	0x0000c000 - 0x0000c007 (0x8) IX[B]
    	[37] -1	0	0x0000d000 - 0x0000d0ff (0x100) IX[B](B)
    	[38] 0	0	0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
    	[39] 0	0	0x000003c0 - 0x000003df (0x20) IS[B](OprU)
    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (WW) fglrx(0): could not detect X server version (query_status=-1)
    (II) Loading sub module "glx"
    (II) LoadModule: "glx"
    (II) Reloading /usr/lib/xorg/modules/extensions//libglx.so
    (II) NVIDIA GLX Module  96.43.05  Tue Jan 22 20:11:30 PST 2008
    (II) Loading extension GLX
    (II) Loading extension ATIFGLRXDRI
    (II) fglrx(0): doing DRIScreenInit
    (II) fglrx(0): DRIScreenInit for fglrx driver
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 8, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 8, (OK)
    drmOpenByBusid: Searching for BusID PCI:1:5:0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 8, (OK)
    drmOpenByBusid: drmOpenMinor returns 8
    drmOpenByBusid: drmGetBusid reports PCI:1:5:0
    (II) fglrx(0): [drm] DRM interface version 1.0
    (II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:5:0"
    (II) fglrx(0): [drm] added 8192 byte SAREA at 0x38000
    (II) fglrx(0): [drm] mapped SAREA 0x38000 to 0xb7efa000
    (II) fglrx(0): [drm] framebuffer handle = 0x39000
    (II) fglrx(0): [drm] added 1 reserved context for kernel
    (II) fglrx(0): DRIScreenInit done
    (II) fglrx(0): Kernel Module Version Information:
    (II) fglrx(0):     Name: fglrx
    (II) fglrx(0):     Version: 8.53.4
    (II) fglrx(0):     Date: Sep  8 2008
    (II) fglrx(0):     Desc: ATI FireGL DRM kernel module
    (II) fglrx(0): Kernel Module version matches driver.
    (II) fglrx(0): Kernel Module Build Time Information:
    (II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.23-chw-4
    (II) fglrx(0):     Build-Kernel MODVERSIONS:        no
    (II) fglrx(0):     Build-Kernel __SMP__:            yes
    (II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
    (II) fglrx(0): [drm] register handle = 0x0003a000
    From looking at some other examples online I think there should be some more stuff output after the register handle line, but I am not sure what is causing it to stop there.

    In the syslog I get

    Code:
    kernel: [fglrx] GART Table is not in FRAME_BUFFER range
    kernel: [fglrx] Reserved FB block: Shared offset:0, size:1000000
    kernel: [fglrx] Reserved FB block: Unshared offset:7ffb000, size:5000
    repeated a number of times, followed by

    Code:
    init: Id "c7" respawning too fast: disabled for 5 minutes
    I have tried with a number of different driver versions, and they all experience the same problem.
    This is running on a machine network booting KnoppMyth R5.5

    Any advice on how to resolve this would be greatly appreciated.

    Many thanks,
    Gerard

  2. #2

    Default

    >> (II) NVIDIA GLX Module 96.43.05 Tue Jan 22 20:11:30 PST 2008 <<

    I would start with this:
    uninstall nvidia-glx

  3. #3
    Join Date
    Nov 2008
    Posts
    3

    Default

    Thanks for the pointer.
    I have tried to uninstall nvidia-glx, although I'm not sure if I've done it correctly.
    I now get the following error in the Xorg log:

    Code:
    (EE) fglrx: Failed to load module "glx" (module does not exist, 0)
    (EE) fglrx(0): Failed to load GLX module.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    I have tried reinstalling the ati drivers, but that doesn't seem to have changed anything.

    Do you have any ideas how to resolve this? Where should this module be located? Can I look for it anywhere?

    Many thanks for your help.

    Regards,
    Gerard

  4. #4

    Default missing GLX

    glx module should install to:
    /usr/lib/xorg/modules/extensions/libglx.so

    some possibilities
    nvidia-glx may not have uninstalled cleanly. depending on your distro, you may have a redirection. (Debian uses dpkg-divert)

    you may have a separate fglrx-glx package that needs to be reinstalled

    also try purging all fglrx packages and then reinstalling them
    also try reinstalling libgl1-mesa-glx or xserver-xorg-core
    -your distro should have a method to find out which package a file belongs to (Debian uses dpkg -S $pathtofile)

    which distro are you running?
    which install method are you using? (*.run file or distro's packages?)

  5. #5
    Join Date
    Nov 2008
    Posts
    3

    Default

    Thanks for your help.

    I think it turned out that nvidia-glx had not been removed correctly. I tried to remove it again and I think it has worked this time.
    Well at least the screen comes up ok, and fglrxinfo reports:
    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon X1200 Series
    OpenGL version string: 2.1.8087 Release
    so I think it is working!

    Thanks a lot for your help.
    Last edited by gezz; 11-05-2008 at 04:17 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •