Results 1 to 4 of 4

Thread: ATI 2600HD in 24" iMac - Horrible Performance

  1. #1

    Default ATI 2600HD in 24" iMac - Horrible Performance

    I am running Ubuntu 8.10 on a 24" 2.8Ghz C2D iMac, 4gb ram, 256Mb ATI 2600HD, etc... And have noticed terrible performance since day one (even back on 8.04, ubuntu, kubuntu).

    I have tried running without Compiz and the performance is no better. glxgears averages at about 1000fps. Compiz about 100fps - 120fps.

    My xorg.conf is bellow:

    Code:
    Section "ServerLayout"
    	Identifier     "aticonfig Layout"
    	Screen      0  "Default Screen" 0 0
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    	Load  "glx"
    EndSection
    
    Section "Monitor"
    	Identifier   "Configured Monitor"
    EndSection
    
    Section "Device"
    	Identifier  "Configured Video Device"
    	Driver      "fglrx"
    	Option	    "XAANoOffscreenPixmaps" "on"
    	Option	    "TexturedVideo" "on"
    	Option	    "VideoOverlay" "off"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "Textured2D" "on"
    	Option	    "UseFastTLS" "1"
    	Option	    "TexturedXrender" "off"
    	Option	    "BackingStore" "on"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
    	Identifier "Default Screen"
    	Device     "Configured Video Device"
    	Monitor    "Configured Monitor"
    	DefaultDepth     24
    EndSection
    
    Section "DRI"
    	Group        "Video"
    	Mode         0666
    EndSection
    
    Section "Extensions"
    	Option	    "RENDER" "Enable"
    	Option	    "DAMAGE" "Enable"
    	Option	    "Composite" "Enable"
    EndSection
    Any help is greatly appreciate. Even if I can boost performance to a normal level, that would be awesome.

    Carl

  2. #2
    Join Date
    Jun 2007
    Location
    Albuquerque NM USA
    Posts
    350

    Default

    What does

    glxinfo | grep direct

    return about the status of direct rendering?

  3. #3
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    NOt sure if it will help but you probably don't need the XAANoOffscreenPixmaps option any more.

    What are you running when you see horrible performance ? Glxgears doesn't count

  4. #4

    Default

    Quote Originally Posted by rbmorse View Post
    What does

    glxinfo | grep direct

    return about the status of direct rendering?
    direct rendering: Yes

    I am running nothing really. I am checking from a fresh reboot, so the usual stuff on a typical Ubuntu system at login. I disabled compiz, cairo-dock, gnome-do and conky for good measure. None of these effected performance greatly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •