Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: UT2K4: ATi Vs nVidia IQ.

  1. #1
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    906

    Default UT2K4: ATi Vs nVidia IQ.

    Hi all...

    I was playing UTK4 good-old deathmatch in the single player "campaign" when I noticed that something looked rather different in the DM-Antalus map. I'm specifically referring to the small "swamp" in the level where the GES BioRifle lies. IIRC there should be some veins and foliage on the surface of the water, however on my computer this area of the map looks completely clean.

    So I was thinking about some comparative screenshots, if anyone with an ATi card can take a screenshot as similar to this perspective as possible, to be able to compare them... IIRC the problem with the nvidia drivers is that they expose less TMUs to UT2K4 than what the card actually has (or something to that effect)


  2. #2
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    906

    Default

    Well... No body seemed to want to help me sort this issue out... So I resorted at borrowing a Window machine with an nVidia card on it and install my copy of Unreal Tournament 2004 onto it, patch the game to latest version (same as the Linux version) and proced to "test"... Here are the "results". I'm still missing shots from an ATi based installation (and preferrably from Windows's D3D and OGL as well as Linux' OGl).

    So trying to find out if the "vines" issue (along with the shadows and headlights issues in the game) was a problem with the OpenGL renderer, nVidia's OpenGL or the game, I decided to see if this same behavior was observed in Windows. Lo and behold, as there are indeed differences... Just I don't know why are these so.



    This is the a screenshot of the game in the same area in the DM-Antalus map as before, taken on Windows XP and running the game in Direct3D. Notice that there are some "vines" (or whatever the heck are those) on the water surface.



    This is another screenshot of the same area in the game, and though it looks exactly the same as the first screenshot in the other post, this is on Windows XP and with the OpenGL renderer, on the same GeForce 9800GT video card. Notice that the "vines" effect is missing from the water surface, jsut like in the first screenshot.

    Searching around this seems to be a problem of the OpenGL renderer with the nVidia OpenGL drivers... Apparently in order for some effects to be rendered, the game (renderer?) requires that the graphics card (driver?) has at least 6 TMUs. Modern graphics cards have much more than that, but maybe this is a "problem" with the drivers not "advertising" the actual number of TMUs? And why is it not a problem in Direct3D?... At any rate, I wanted to rule out an OpenGL renderer problem in the game or if it was due to the nVidia drivers (hence the call to compare with ATi)

  3. #3

    Default

    Sorry I couldn't help Thetargos. I mean... I don't even own UT2k4...

  4. #4
    Join Date
    Dec 2007
    Posts
    671

    Default

    more reason to buy ATI

  5. #5
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,587

    Default

    IIRC correctly this was mentioned a long time ago when UT2003/4 came out. I could be wrong but I seem to recall it's an issue with the openGL renderer in the game. Don't think it ever got fixed.

  6. #6
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    68

    Default

    Works good on my Ati card. Its an old Radeon X550 with catalyst 8.10 on linux.
    Last edited by poofyyoda; 11-20-2008 at 03:53 AM.

  7. #7
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    906

    Default

    Thanks a LOT poofyyoda... I found an old e-mail from Ryan Gordon stating that this is indeed a problem with the nVidia driver rather than the OpenGL renderer itself. Apparently nVidia claims it is a problem with the game, and Epic claims it is a problem with the drivers... As evidenced by your screenshot, it indeed seems to be a problem with the drivers, rather than the game... Do you get the other effects as well? (License Plate on the Hellbender, Shadows and the scoreboard on another map (sorry I do not remember the name of map right now)).

    You gotta love the irony from a game that sports "The Way It Is Meant To Be Played" slogan and fails to do deliver on a plaform that the game can only be played with the unsupported renderer.

  8. #8
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    68

    Default

    here you go..


    It looks like the scoreboards a bit off, but hey it works



    To get shadows and render to texture the ini's have to be editted though

    ut2004.ini:
    UseRenderTargets=True

    User.ini:
    bPlayerShadows=True
    bBlobShadow=False

  9. #9
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    906

    Default

    Thanks. I doubt nVidia will address the issues with this particular game, however, if another (newer) game has the same restrictions (or similar), I wonder if this would classify as a bug report to nVidia... I'd imagine it would, I have to first find another game that may have this problem. Will test on Linux with those "hacks", though.

  10. #10
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    906

    Default

    There seems to be a serious regression in the nVidia 180.x drivers. The changes in the .ini files indeed yield the expected results, however performance suffers, and a LOT, not what you'd expect to see with a reasonably decent video card. Performance drops to 10 FPS in Onslaught games, granted all settings in High/Highest, but with my previous card (8500GT) and different drivers performance was reasonably (Ons-Torlan yielding about 40 FPS average); 10-20 FPS in this game with a 9800GT card is certainly not what you'd expect to get (indeed the Windows system I borrowed for the other tests is almost identical to my main rig).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •