Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: System freezes while watching a video with VLC

  1. #1
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default System freezes while watching a video with VLC

    While watching a video with VLC in full-screen the system freezes occasionally, even magic-keys don't work to take back control or reboot safely.

    I'm using catalyst 9.2 on a Mobility HD3650.

  2. #2
    Join Date
    Oct 2007
    Location
    UK
    Posts
    160

    Default

    i get the same on my hd4850 on catalyst 9.2 or 9.1.
    I found compiz/emerald was the culprit. Try to disable it and see
    if it happens again.

  3. #3
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    I don't use a compositing window manager, no compiz/beryl, just plain KDE 4.2. Yesterday I got another freeze this time using Kaffeine.

  4. #4
    Join Date
    Jan 2009
    Location
    Serbia
    Posts
    3

    Default

    KWin compositing effects are switched on by default in KDE 4.2. Did you switch them off? (System Settings->Desktop->Desktop Effects)

  5. #5
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    Quote Originally Posted by dokc View Post
    KWin compositing effects are switched on by default in KDE 4.2. Did you switch them off? (System Settings->Desktop->Desktop Effects)
    Yes, all desktop effects are disabled, as I see no need for them.

    With desktop effect enabled the problem is a horrible video flicker, but as I said before, I have no compositing window manager enabled, and the problem is a hard lock while playing a video.

    I tried with opengl (textured) video and overlay, and both cause a lockup.

  6. #6
    Join Date
    Mar 2009
    Posts
    54

    Default

    Quote Originally Posted by glock24 View Post
    Yes, all desktop effects are disabled, as I see no need for them.

    With desktop effect enabled the problem is a horrible video flicker, but as I said before, I have no compositing window manager enabled, and the problem is a hard lock while playing a video.

    I tried with opengl (textured) video and overlay, and both cause a lockup.
    Try turning textured video off. I have the same problems and turning textured video off has solved it for me. I also had this with the previous 9.1 catalyst version.

    Regards,

    Eddie.

  7. #7
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,283

    Default

    A couple of points:

    1. "Desktop Effects" normally require a compositing window manager, and enable compositing automatically when you enable desktop effects. There may be exceptions to this, of course.

    2. AFAIK you can't really turn TexturedVideo off for 5xx and higher GPUs, since they don't have the same video processing hardware in the overlay block.

    Mr. Ed, which GPU are you running ?

  8. #8
    Join Date
    Mar 2009
    Posts
    54

    Default

    Dear Bridgeman,

    I have the following GPU: RV350 AR [Radeon 9600] rev 0.

    I am sorry for my bad reply but I did not know that texturedvideo for newer ATI graphic boards can't be turned off.

    Altough I do know that my graphic board has hard coded overlay support, I experimented with the texturedvideo parameter to see if it enabled me to play xv video using a composite window manager desktop. And it actually did gave me some positive results although the video was flickering.

    Since 9.1 I am forced to turn it off because when I use totem movie player to play a video with texturedvideo = on, the screen turns black and the system locks up.

    So, thatswhy I thought it might help for Glock24.

    With kind regards,

    Eddie.

  9. #9
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    Desktop effect are disabled, I disable them as I find them annoying.

    In Kaffeine (whick uses xine backend) the only video output options that work are xv and xshm, and both cause lockups. As i understand, textured video work only with opengl output, right? So textured video is not causing the lockups.

    I currently these options on my xorg.conf:

    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"

    also tested with:

    Option "VideoOverlay" "off"
    Option "OpenGLOverlay" "on"

    But the result is the same. I noticed that the lockups are more frequent when playing a video after the computer wakes up from suspend.

  10. #10
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,283

    Default

    Mr. Ed; sorry, I just saw your post. Makes sense.

    glock24; textured video uses the 3D engine but does not use OpenGL. For your system the normal settings would be :

    TexturedVideo on
    VideoOverlay off (5xx and higher don't have a video processor in the overlay block)
    OpenGLOverlay off (this is for workstation apps which float another layer of graphics over the work area)

    It sounds like the common thread here is some hanging during textured video playback (??)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •