Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: System Freeze on Switch user

Hybrid View

  1. #1
    Join Date
    May 2008
    Posts
    3

    Default System Freeze on Switch user

    I'm running Ubuntu 8.1 64 bits.
    Have 4g of ram. using radeon 3650 card

    whenever i do a switch user, the system freezes.
    If i do a logout and the log in all works.

    This issue has been going on now for approx 6 months. I thought the newest ubuntu & ati drivers would solve it.
    Any ideas if this is specific to myhardware or if other users are also facing it.

    Any ideas on how to solve it ?

  2. #2

    Default

    Has it ever worked with this specific HW combination?
    If it has, then it was likely a software change at that time. Please check your package manager logs to see if they go back that far.

    If it hasn't:
    Remove some RAM. Some systems have funky configuration needs if you have 4GB or more. If this fixes it, you may need to change BIOS settings.

    Update your BIOS. Some BIOSes have bugs in how they detect and configure your hardware.

    Also:
    Please get dmesg and Xorg.0.log from a crash, if possible.

  3. #3
    Join Date
    Sep 2008
    Posts
    27

    Default

    I have the same problem, and I've had it since I bought my 3870. My old X600 worked perfectly with the same hardware.
    It only happens with the fglrx driver though.
    See this bug at launchpad for more frustrated users: #112518

  4. #4

    Default

    Odur, thanks for the info. Your link also reports it happening with nvidia drivers as well. There seem to be at least 2 bugs with similar profiles here, possibly more. One is fixed by disabling SyncToVblank in compiz (causes hard lock with white screen). Another is an invisible login prompt. I get this with OpenGL screensavers. There may be another bug as well.

    4GB RAM w/ bad BIOS causes problems
    IRQ settings causes problems
    disabling APIC causes problems
    compiz w/ SyncToVblank causes problems
    fglrx doesn't seem to work right with some newer cards
    xorg may have its own issues

    milanvora, is the whole system locked (not pingable) or just the console? (display, keyboard, mouse) Do you get white screen or black?

  5. #5
    Join Date
    Jun 2008
    Posts
    51

    Default

    I have the same problem with fglrx.

    I had no problems until I switched my (very) old Matrox card for an ATI 3450 6 months ago. Since using fglrx I can't switch user. I can switch user if I use radeonhd driver, but then I can't watch video due to lack of driver support.
    Therefore the problem is clearly in fglrx.

    Perhaps there is a config change that can be done to fix this? I'm using default config.
    However, this issue has been mentioned repeatedly over the last 6 months (at least), and the ATI devs response was along the lines of "switch user? who uses that?", so don't hold your breath waiting for a fix because they don't really seem to care.

    Give it long enough and radeonhd will be usable. Of course, your video card might be obsolete by then...

  6. #6
    Join Date
    Dec 2008
    Location
    San Bernardino, CA
    Posts
    231

    Default

    I am running 64bit Ubuntu Hardy 8.04 LTS. I too have the problem of screen freezing and system becoming unresponsive on switch user in Gnome with the fglrx driver. Works fine with radeonhd, but then I get no 3d acceleration on my 4670 card!

    To AMD/ATI: When will this problem be fixed? I see it still in the latest Catalyst 8.12

  7. #7
    Join Date
    Sep 2008
    Posts
    27

    Default

    Still happens in fglrx 9.1. Switch user and you go straight to hard-lock hell.

    Hey, bridgeman. Would you be kind and pass this information to the fglrx-developers. I can't see no explanation other than they don't know about this bug.

  8. #8

    Default

    Also, OpenGL screensavers can cause problems

    Try disabling screen saver (set to blank only)

  9. #9
    Join Date
    Sep 2008
    Posts
    27

    Default

    When I try to switch user with fglrx loaded the system gets totally unresponsive. It's not pingable, no ssh, no nothing. A total and complete hard lock with a black screen.

  10. #10

    Default

    Odur, Does it still lock if you disable composite? Or if you enable it? Some people have reported <i>enabling</i> composite can fix it.

    Also, try disabling DRI in xorg.conf.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •