Page 5 of 5 FirstFirst ... 345
Results 41 to 48 of 48

Thread: System Freeze on Switch user

  1. #41
    Join Date
    Sep 2008
    Posts
    27

    Default

    It worked for me with my old X600 card. But that was almost a year ago...

  2. #42
    Join Date
    May 2008
    Posts
    45

    Default

    Quote Originally Posted by Odur View Post
    I tried the suggested solution in message 174 on page 7 in that thread. Didn't do any good at all...
    modprobe -r fglrx && modprobe fglrx
    before typing startx does help against black screen on second login

  3. #43
    Join Date
    Sep 2008
    Posts
    27

    Default

    Quote Originally Posted by alec View Post
    modprobe -r fglrx && modprobe fglrx
    before typing startx does help against black screen on second login
    Could you explain that in detail? I have no luck whatsoever, so maybe I'm doing something wrong.

  4. #44
    Join Date
    May 2008
    Posts
    45

    Default

    Quote Originally Posted by Odur View Post
    Could you explain that in detail? I have no luck whatsoever, so maybe I'm doing something wrong.
    I don't use gdm or kdm so after I log out of XFCE I am at VC/1
    usually if I try to xtartx or xinit after that, my pc hangs

    but when I tried that command, which basically reloads fglrx module (?), next xinit was normal.

  5. #45
    Join Date
    Sep 2008
    Posts
    27

    Default

    Oh, I see. Not exactly the same problem then.

  6. #46
    Join Date
    May 2008
    Posts
    45

    Default

    there are several supgroups to this problem. For some it freezes on logout, for some on starting xinit (which is involved in user switching)

  7. #47
    Join Date
    Sep 2008
    Posts
    27

    Default

    Yes, of course. They are definitely related. I just meant that it was not exactly the same problem as I have, and that is why that solution doesn't work for me.

    If I start another VT and try to unload the fglrx module, I get a fatal error because the module is in use in my other session.

  8. #48
    Join Date
    Sep 2008
    Posts
    27

    Default

    Update: fglrx 9.04 still has the same problem. The only change to my system is that I have installed Kubuntu Jaunty instead of Intrepid.

    Next time I'll buy an Nvidia...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •