Page 6 of 9 FirstFirst ... 45678 ... LastLast
Results 51 to 60 of 87

Thread: Creative Gives In, They Open-Source Their X-Fi Driver

  1. #51
    Join Date
    Aug 2007
    Posts
    29

    Default

    For myself I am really glad this has happened.

    The last add in sound card I bought was an Audigy2zs. The SB0350 models of the Audigy2zs cards are/were the best cards for Linux imo.

    I don't like dmix and software mixing. It just adds more trouble to the configure stage for getting proper audio. The Audigy2zs cards did this for me so I never had to mess with dmix or anything for sound playback from multiple sources at the same time.

    This is why I am excited over this news. If the X-fi cards are capable of the same multi-channel sound source playback without any hassle then I will definately pick one up. The sound quality would almost have to be superior to even the audigy2zs I would think.

    I never use onboard sound chips as they are all flaky with static or just don't have that rounded sound feeling. They would either be tingy or bassy but never have good output. That's why I love my Audigy2zs's. I have these in all my comps currently and even buy ones that are either still new or in still new condition so I can sell them in my Linux box's that I sell.

    Nothing I have ever done for sound in Linux has come close to the usefullness of an Audigy2zs for sound. Hopefully the X-fi cards will be my new cards that I look forward to using instead of buying $30-160 Audigy2's.

  2. #52
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    899

    Default

    Indeed! And that is why I have been recommending people to get Creative Emu10K* based cards for Linux for the longest time! Of course they are not the only ones that provide these features (especially hardware mixing), but are the highest profile ones that do. I wonder if any of the other CMI-based high-end cards also do hardware mixing and up to how many sources? Oh, and wasn't originally the DSP of the X-Fi called EMU20K1 (or was that another chip/architecture different to the X-Fi)?

  3. #53
    Join Date
    Oct 2007
    Posts
    31

    Default

    Actually, for your consideration, I "DID" try what you want to know..

    I put my Audigy2 ZS in stereo configuration (disabling the rest of speakers) and trying out different programs, musics and EQ settings and then I put the X-Fi back in... the results are staggering to say the least.

    The quality that is coming out of the X-Fi is simple astounding, it even rivals my Xonar DX in linux (Xonar is doing better in windows for now).

    Comparing X-Fi in stereo with Audigy2 is like comparing seeing a flower or a kick in the balls (quality speaking).

    You cannot compare the two, Audigy2 lacks the deep bass quality the X-Fi is outputing on the fronts (I have a VERY good pair of Yamaha 200W RMS speakers with a 100W x 2 Receiver), X-Fi definetly sounds "Hi-Fi-ish" on Linux now, I actually like it A LOT, and I'm some kind of audiophile so, take my consideration.

    Actually, I don't think you need Crystalizer at all in Linux for now.


    PD: X-fi is Emu20k1 and DO hardware mixing in the current driver (or so it seems)
    PD2: I have xonar dx (c-media oxygen hd based, yes, both cards on the same machine, i'm a freak) Oxygen HD DOES NOT support hardware mixing, at all, I use Pulse Audio for that.

  4. #54
    Join Date
    Jun 2006
    Posts
    99

    Default

    Are these drivers only working with the 2.6.27 kernel and above? I installed on OpenSuSE 11.0 with 2.6.25. Everything installed fine, the module is inserted just fine, however, there is no sound.

  5. #55
    Join Date
    Jan 2007
    Location
    UK
    Posts
    16

    Default

    I think it's only working on 2.6.27. The module wouldn't build with 2.6.25 for me.

  6. #56
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    899

    Default

    What API does the driver use? OSS or ALSA? If ALSA, maybe in the spirit of good-ol' ALSA the driver is muted when inserted, and are you able to run the mixer from the console (alsamixer or if you have PulseAudio running alsamixer -c 0)?

  7. #57
    Join Date
    Jun 2008
    Posts
    55

    Default

    Quote Originally Posted by ppanula View Post
    OMG! Finally i can install eg. Ubuntu to my Game-PC...

    Hope this will go quickly to ALSA...
    In fact, the open-source driver *does* work in Ubuntu (in fact, I'm *using* it in Ubuntu Intrepid Ibex right now, listening to an audiobook in the background, as I type these words).

    (watches the 1st Tactical Bombardment Squadron ("The Prokchops") practicing acrobatics in the distance over several partially-frozen demons)

  8. #58
    Join Date
    Jun 2008
    Posts
    55

    Default

    Quote Originally Posted by Thetargos View Post
    What API does the driver use? OSS or ALSA? If ALSA, maybe in the spirit of good-ol' ALSA the driver is muted when inserted, and are you able to run the mixer from the console (alsamixer or if you have PulseAudio running alsamixer -c 0)?
    It's ALSA-native (thus the existing ALSA mixer and tools will work). I'm using the drivers right now.

  9. #59
    Join Date
    Sep 2007
    Posts
    2

    Default OpenSUSE 11

    Quote Originally Posted by KohlyKohl View Post
    Are these drivers only working with the 2.6.27 kernel and above? I installed on OpenSuSE 11.0 with 2.6.25. Everything installed fine, the module is inserted just fine, however, there is no sound.
    I haved same problem too. Before i haved oss4 and i think that oss4 rewrited some alsa libraries. After reinstalling alsa, alsa libraries, alsa utilities and other sound/alsa related packages X-Fi is running in all apps.

  10. #60
    Join Date
    Oct 2007
    Posts
    88

    Default

    If you have a front panel, it wont work. You need to plug your stereo or headphones into the back of your computer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •