Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: X1250 + fglrx + HDMI: X will not start

  1. #11
    Join Date
    Nov 2008
    Posts
    14

    Default

    Sorry, I was busy last days.

    Code:
    (II) RADEON(0): EDID data from the display on output: HDMI-0 ----------------------
    (II) RADEON(0): Manufacturer: FUS  Model: 7a6  Serial#: 1
    (II) RADEON(0): Year: 2008  Week: 39
    (II) RADEON(0): EDID Version: 1.3
    (II) RADEON(0): Digital Display Input
    (II) RADEON(0): Max Image Size [cm]: horiz.: 51  vert.: 29
    (II) RADEON(0): Gamma: 2.20
    (II) RADEON(0): DPMS capabilities: Off
    (II) RADEON(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
    (II) RADEON(0): First detailed timing is preferred mode
    (II) RADEON(0): redX: 0.644 redY: 0.336   greenX: 0.295 greenY: 0.614
    (II) RADEON(0): blueX: 0.146 blueY: 0.072   whiteX: 0.313 whiteY: 0.329
    (II) RADEON(0): Supported VESA Video Modes:
    (II) RADEON(0): 720x400@70Hz
    (II) RADEON(0): 640x480@60Hz
    (II) RADEON(0): 640x480@75Hz
    (II) RADEON(0): 800x600@60Hz
    (II) RADEON(0): 800x600@75Hz
    (II) RADEON(0): 1024x768@60Hz
    (II) RADEON(0): 1024x768@75Hz
    (II) RADEON(0): 1280x1024@75Hz
    (II) RADEON(0): Manufacturer's mask: 0
    (II) RADEON(0): Supported Future Video Modes:
    (II) RADEON(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
    (II) RADEON(0): #1: hsize: 1600  vsize 1200  refresh: 60  vid: 16553
    (II) RADEON(0): #2: hsize: 1440  vsize 900  refresh: 60  vid: 149
    (II) RADEON(0): #3: hsize: 1680  vsize 1050  refresh: 60  vid: 179
    (II) RADEON(0): Supported additional Video Mode:
    (II) RADEON(0): clock: 148.5 MHz   Image Size:  509 x 286 mm
    (II) RADEON(0): h_active: 1920  h_sync: 2008  h_sync_end 2052 h_blank_end 2200 h_border: 0
    (II) RADEON(0): v_active: 1080  v_sync: 1089  v_sync_end 1095 v_blanking: 1125 v_border: 0
    (II) RADEON(0): Ranges: V min: 49 V max: 76 Hz, H min: 15 H max: 82 kHz, PixClock max 170 MHz
    (II) RADEON(0): Monitor name: LSL 3230T
    (II) RADEON(0): Serial No: YE8J003765
    (II) RADEON(0): Number of EDID sections to follow: 1
    (II) RADEON(0): EDID (in hex):
    (II) RADEON(0): 	00ffffffffffff001ab3a60701000000
    (II) RADEON(0): 	2712010380331d782ac9a5a4564b9d25
    (II) RADEON(0): 	125054a54b008180a9409500b3000101
    (II) RADEON(0): 	010101010101023a801871382d40582c
    (II) RADEON(0): 	9600fd1e1100001e000000fd00314c0f
    (II) RADEON(0): 	5211000a202020202020000000fc004c
    (II) RADEON(0): 	534c2033323330540a202020000000ff
    (II) RADEON(0): 	005945384a3030333736350a20200157
    finished output detect: 1
    finished all detect

  2. #12
    Join Date
    Sep 2006
    Posts
    353

    Default

    So, this modeline would be good for you:

    # 1920x1080 @ 60Hz hsync: 67.5kHz (EDID from Fujitsu-Siemens, Amilo LSL 3230T)
    Modeline "1920x1080" 148.5 1920 2008 2052 2200 1080 1089 1095 1125 +hsync +vsync

  3. #13
    Join Date
    Sep 2006
    Posts
    353

    Default

    Quote Originally Posted by Jade View Post
    So, this modeline would be good for you:

    # 1920x1080 @ 60Hz hsync: 67.5kHz (EDID from Fujitsu-Siemens, Amilo LSL 3230T)
    Modeline "1920x1080" 148.5 1920 2008 2052 2200 1080 1089 1095 1125 +hsync +vsync
    mactas, did you fudge the raw modeline numbers a tiny bit?

    You see, together they don't correspond to any other EDID info I have found.


    # 1920x1080 @ 24 Hz (EDID) HSync: 26.9673 kHz
    ModeLine "1920x1080" 74.16 1920 2558 2602 2750 1080 1084 1089 1125 +Hsync +Vsync
    # 1920x1080 @ 25 Hz (EDID) HSync: 28.125 kHz
    ModeLine "1920x1080" 74.25 1920 2448 2492 2640 1080 1084 1089 1125 +Hsync +Vsync
    # 1920x1080 @ 30 Hz (EDID) HSync: 33.7159 kHz
    ModeLine "1920x1080" 89.01 1920 2448 2492 2640 1080 1084 1089 1125 +Hsync +Vsync
    # 1920x1080 @ 50 Hz (EDID) HSync: 56.25 kHz
    ModeLine "1920x1080" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +Hsync +Vsync
    # 1920x1080 @ 60 Hz (EDID) HSync: 67.4318 kHz
    ModeLine "1920x1080" 148.35 1920 2008 2052 2200 1080 1084 1089 1125 +Hsync +Vsync
    # 1920x1080 @ 60 Hz (EDID) HSync: 67.5 kHz
    ModeLine "1920x1080" 148.50 1920 2008 2052 2200 1080 1084 1088 1125 -Hsync -Vsync
    # 1920x1080 @ 50 Hz (EDID) HSync: 28.125 kHz
    ModeLine "1920x1080" 74.25 1920 2448 2492 2640 1080 1084 1094 1124 +Hsync +Vsync Interlace
    # 1920x1080 @ 60 Hz (EDID) HSync: 33.7182 kHz
    ModeLine "1920x1080" 74.18 1920 2008 2052 2200 1080 1084 1094 1124 +Hsync +Vsync Interlace
    Last edited by Jade; 11-18-2008 at 05:37 AM.

  4. #14
    Join Date
    Nov 2008
    Posts
    14

    Default

    still my X does not start, even with fglrx 9.01 and ubuntu 8/10. I can see the spashscreen end even the console. but x will not start. there aren't any errors in the x-log.

  5. #15
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,440

    Default

    A couple of things :

    1. Some people are reporting a "boot to black screen" problem when they restart after using aticonfig commands to get rid of the underscan. Resetting or deleting the amdpcsdb file seems to get around that, although underscan comes back. I think you need to run aticonfig --initial after deleting admpcsdb but not 100% sure.

    2. Installing fglrx over-writes some files which are used by radeon (and newer versions of radeonhd). You need to uninstall fglrx completely to use radeon or radeonhd; you can't just switch back and forth by changing the conf file.

    HTH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •