Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 68

Thread: AMD Catalyst 8.11 Linux Driver Released

  1. #21
    Join Date
    Aug 2008
    Posts
    15

    Default

    Tares, just remove all packages and use the automated installer... I can't do packages anymore unless they are synaptic based... Some glitch in the installer causes a version mismatch with one of the modules...

    Long story short I just used the automated installer.

  2. #22
    Join Date
    Aug 2008
    Posts
    15

    Default

    Also if you haven't gotten backing store to work with the new xorg/xserver using the synaptic package, turn it off... It didn't work for me, and with 1066 dual channel I really don't notice a difference so I haven't bothered testing it again...

  3. #23
    Join Date
    Jul 2008
    Posts
    1,731

    Default

    Tares, your installation is messed up. You are loading the glx module from X instead of the driver and you are trying to load the 8.10 or earlier driver and not 8.11.

  4. #24
    Join Date
    Jan 2008
    Posts
    17

    Default

    I still cant minimize 3d applications.
    http://ati.cchtml.com/show_bug.cgi?id=1278
    Back to 8.8.

  5. #25
    Join Date
    Oct 2007
    Location
    Poland
    Posts
    197

    Default

    Quote Originally Posted by Methylene View Post
    Also if you haven't gotten backing store to work with the new xorg/xserver using the synaptic package, turn it off... It didn't work for me, and with 1066 dual channel I really don't notice a difference so I haven't bothered testing it again...
    Thanks Methylene. Using --install works. Well I've disabled loading dri/glx/glcore and turned off backing store, but I doubt that had any impact ;-)

    Anyway with this release, amdcccle still reports that my fglrx works in mesa mode :/

  6. #26
    Join Date
    Aug 2007
    Posts
    6,646

    Default

    Disable Xgl.

  7. #27
    Join Date
    Nov 2008
    Posts
    5

    Default

    I followed the instructions on CCHTML wiki (I did it multiple times before for Ubuntu 8.04 and ATI 8.10 driver) and got problems. This guy had the same problem:

    http://www.mail-archive.com/ubuntu-b...sg1149141.html

    I am using Xubuntu 8.10.

  8. #28
    Join Date
    Oct 2007
    Location
    Poland
    Posts
    197

    Default

    Quote Originally Posted by Kano View Post
    Disable Xgl.
    I don't have it even installed, AIGLX turned off.

  9. #29
    Join Date
    Jul 2008
    Posts
    1,731

    Default

    Tares, deinstall everything and wait for the ubuntu package, ok? And please check your system thoroughly for stale files.

  10. #30
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    Hi, I installed Catalyst 8.11 yesterday after reupgrading to XServer 1.5.
    However, when I boot into graphical mode (i.e. start the x server), Xorg.log says:
    (II) fglrx(0): ***Display: ConnectedDisplayTypes=0x00000010, disabled=0x00000000
    (II) fglrx(0): Connected Display1: CRT on secondary DAC [crt2]
    (II) fglrx(0): Display1: No EDID information from DDC.
    (EE) fglrx(0): Unknown EDID version 0
    (II) fglrx(0): Display1: Failed to get EDID information.
    And then it falls back to 640x480, though it should use 1280x1024..
    Is there any way to force fglrx to use the better resolution (Note: I can switch to 1280x1024 by using KRandrTray or so, if that's useful information)?
    This is on an ATI 3850.

    And by the way, there is a VERY painful bug causing window resizing (at least in Compiz) to have a delay of multiple seconds...

    EDIT: Oh, well... the log goes further:
    (EE) fglrx(0): Unknown EDID version 0
    (II) fglrx(0): Display1: Failed to get EDID information.
    (WW) fglrx(0): Only one display is connnected,so single mode is enabled
    (II) fglrx(0): Primary Controller - CRT on secondary DAC
    (II) fglrx(0): Internal Desktop Setting: 0x00000001
    (==) fglrx(0): QBS disabled
    (==) fglrx(0): FAST_SWAP disabled
    (==) fglrx(0): PseudoColor visuals disabled
    (==) fglrx(0): Center Mode is disabled
    (==) fglrx(0): TMDS coherent mode is enabled
    (II) fglrx(0): Total of 2 modes found for primary display.
    So I guess the problem can be reduced to finding a way to tell fglrx to actually use the higher resolution, but specifying the resolution via aticonfig didn't work...
    Last edited by NeoBrain; 11-14-2008 at 10:18 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •