Results 1 to 3 of 3

Thread: Locking issues with Catalyst 8.11

  1. #1
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,750

    Default Locking issues with Catalyst 8.11

    Anyone else noted strange locking issues with this driver and a few past it? If I open a terminal and try to move it, my computer enters a hard lock. I can't even SSH into the computer anymore, it's just dead until reboot. Then if I run 3D applications for extended periods, my computer is likely to end up in a soft lock, for maybe 10 seconds or so. These two incidents might not be related but I'd like users to comment if anyone else is suffering from either plus I'd be happy for advice on debugging the kernel module since the hard lock is pretty obviously the fglrx kernel module's fault. (At least afaik it's impossible to do that in userspace)

  2. #2
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,750

    Default

    Hmm, since someone is bound to ask anyway, running X.org server 1.5.2 and kernel version 2.6.27 with APIC support. Do I need some kexec+kdump trick to retrieve the debug information from the hard lock or is there an easier way?

  3. #3
    Join Date
    Oct 2008
    Posts
    10

    Default

    Quote Originally Posted by nanonyme View Post
    Hmm, since someone is bound to ask anyway, running X.org server 1.5.2 and kernel version 2.6.27 with APIC support. Do I need some kexec+kdump trick to retrieve the debug information from the hard lock or is there an easier way?
    Sounds close to what I am getting. With gentoo 64bit, xorg 7.4(1.5.2), ati 8.552, kernel 2.6.27-7, 790gx based MB with a Phenom 8450 (triple core) and gcc 4.3.2. If I move around a kterm my system stalls. Its not reachable via ssh either.

    Worst that happen with the old version (7.3/8.542) were X stalls which I could recover from via ssh from another box.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •