Results 1 to 2 of 2

Thread: xorg.conf for mythtv on screen1 (tv-out)?

  1. #1
    Join Date
    Mar 2008
    Posts
    14

    Default xorg.conf for mythtv on screen1 (tv-out)?

    I want to have mythtv frontend run only on the TV-OUT screen (currently screen1) and leave the monitor (screen0) alone, with the two at different resolutions. At the moment it starts on screen0, which is not what is needed. (I want to configure the system using the monitor, but this will eventually be a DVR, and mythtv-frontend has to come up automatically on TV-OUT.)

    The nvidia proprietary driver is working, tv-out works, but so far I have only been able to get the Monitor (1280 x 1024) as screen 0, and TV-out (640 x 480) as Screen1. When Mythbuntu starts up it puts the mythtv frontend on screen0, but I want it on screen1. Twinview is off and screen1 is to the right of screen 0, I tried swapping all the *0 and *1 lines in xorg.conf, but it wouldn't load module "type1" that way and X11 would not start. So far I have not been able to find the place where mythfrontend configures the choice of screen, as I suspect that would be the simplest way to get the desired result.

    Failing that, is there not a way to swap the screens around?

    The current xorg.conf is:

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@palmer)  Mon Nov  3 08:46:46 UTC 2008
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Sony CPD-420GS"
        HorizSync       30.0 - 96.0
        VertRefresh     48.0 - 120.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: unknown, VertRefresh source: unknown
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "TV-0"
        HorizSync       0.0 - 0.0
        VertRefresh     0.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8400 GS"
        BusID          "PCI:1:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8400 GS"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "CRT: 1280x1024 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen1"
        Device         "Device1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "TV: 640x480 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    This is the one with 0 <-> 1, which won't start

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@palmer)  Mon Nov  3 08:46:46 UTC 2008
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: unknown, VertRefresh source: unknown
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "TV-0"
        HorizSync       0.0 - 0.0
        VertRefresh     0.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "Sony CPD-420GS"
        HorizSync       30.0 - 96.0
        VertRefresh     48.0 - 120.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8400 GS"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8400 GS"
        BusID          "PCI:1:0:0"
        Screen          0
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "TV: 640x480 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen1"
        Device         "Device1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "CRT: 1280x1024 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Thanks.

  2. #2
    Join Date
    Nov 2008
    Posts
    6

    Default

    "DISPLAY=:0.1 mythfrontend"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •