Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Problem with fglrx 8.11 and Fedora 10 (preview)

  1. #11
    Join Date
    Jun 2007


    Quote Originally Posted by Kano View Post
    dkms status
    fglrx, 8.552,, i686: installed

    [Edit] Ah yes, the first line in /var/log/boot.log is this, which has been reported by others on fedoraforum as well:
    FATAL: Error inserting fglrx (/lib/modules/ Operation not permitted
    Last edited by Christian_L; 11-25-2008 at 01:49 AM.

  2. #12
    Join Date
    Oct 2007


    I tried this out when 8.11 came out.

    The bad kernel module was the radeon driver being loaded. I initially tried

    a) Adding "blacklist radeon" to /etc/modprobe.d/ati
    b) uninstalling the xorg*ati*rpm package
    c) removing the "rhgb" and adding "nomodeset" options to /boot/grub/menu.lst to stop the graphical boot

    However the radeon module was still loaded

    I then (after the above) rebuilt initrd , and after a reboot - no ati module!

    I then installed the fglrx drivers (I tried both the feed on rpmfusion, as well as an install from the official driver, but in neither case could I get sensible behaviour

    More details here ->

    Note that interestingly I had no issues with changing xorg to run "radeonhd" instead of "radeon" -- not that radeonhd was any better, indeed I think ati works the best.

    Overally the opensource ati is working fairly well for desktop. 3D comes and goes dependent on the kernel/ati updates from the update feeds. more on that here ->

  3. #13
    Join Date
    Aug 2007


    Well radeon/drm may not be loaded, thats clear. If it is in the initrd you can unload it maybe or change the initrd. On debian blacklisting and then

    update-initramfs -u

    would work, no idea what fedora uses.

  4. #14
    Join Date
    Jun 2007


    There was a fix reported on fedoraforum

    Didn't change anything for me, though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts