Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: How to Catalyst 8.11 on Ubuntu 8.10?

  1. #11
    Join Date
    Aug 2007
    Posts
    6,613

    Default

    Well maybe it does. At least you can use my script now too - it also automatically restarts X and unloads the old modules. With enough ram you can use it even in live mode.

  2. #12
    Join Date
    Aug 2007
    Posts
    6

    Default

    @Kano 10x for the script it works for me but after i restart my laptop

  3. #13
    Join Date
    Aug 2007
    Posts
    6,613

    Default

    Well fglrx somehow stupid, especially when switching from ati to fglrx then you can get a hardlock. If you know that this will happen use -z option and reboot manually. Switching between fglrx drivers usually does not lock the system.

  4. #14
    Join Date
    Feb 2007
    Posts
    83

    Default

    Thanks for the script Kano, worked great for me

  5. #15
    Join Date
    Mar 2008
    Posts
    29

    Default doesn't work with 9700 mobility on intrepid

    sudo modprobe -v fglrx
    FATAL: Error inserting fglrx (/lib/modules/2.6.27-10-generic/updates/dkms/fglrx.ko): Cannot allocate memory


    Xorg.0.log

    (II) Primary Device is: PCI 01@00:00:0
    (WW) Falling back to old probe method for fglrx
    (II) ATI Proprietary Linux Driver Version Identifier:8.55.2
    (II) ATI Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.552
    (II) ATI Proprietary Linux Driver Build Date: Oct 28 2008 21:22:33
    (WW) This ATI Proprietary Linux Driver does not guarantee support of video driver ABI higher than 2.0
    (WW) Video driver ABI version of the X server is 4.1
    (--) Assigning device section with no busID to primary device
    (EE) No devices detected.

    Fatal server error:
    no screens found

  6. #16
    Join Date
    Nov 2008
    Posts
    4

    Default

    The new script worked perfectly for me. Thanks for the help!

  7. #17
    Join Date
    Aug 2007
    Posts
    6,613

    Default

    No problem, it took a bit time to discover what was going on wrong, but then it was easy. I am used to fix ati packageing faults or adding extra kernel hotfixes - you see that when you look at the size of the script Saidly I can not fix the driver itself. Try nexuiz and change res inside the game for example...

  8. #18
    Join Date
    Apr 2007
    Location
    Michigan
    Posts
    51

    Default

    I had success with Kano's script, fglrx is installed and working on 8.10 kubuntu, the process takes a fair bit of time on satelite.

  9. #19
    Join Date
    Oct 2007
    Posts
    86

    Default

    Perfect Script!! Amd should Hire you kano!

    Just run it and everything is done for you... I'm... gratefull

  10. #20
    Join Date
    Dec 2008
    Posts
    1

    Default

    I'm having a very odd problem. I've got a fresh install of Intrepid, and I've attempted to install the new Catalysts with both this script and the standard ATI installation script. I can get both to work correctly after the first reboot. However, after I reboot again the machine crashes hard and falls to a blank screen when X tries to start. The module seems to be loaded correctly. The log is basically the same as the one posted earlier that ends with "(EE) No devices detected." Between reboots I'm doing nothing other than a glxinfo | grep render to make sure things are working. Anyone have any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •